summaryrefslogtreecommitdiff
path: root/user/lxqt-notificationd
diff options
context:
space:
mode:
Diffstat (limited to 'user/lxqt-notificationd')
-rw-r--r--user/lxqt-notificationd/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/user/lxqt-notificationd/APKBUILD b/user/lxqt-notificationd/APKBUILD
new file mode 100644
index 000000000..8a91eeb05
--- /dev/null
+++ b/user/lxqt-notificationd/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=lxqt-notificationd
+pkgver=0.12.0
+pkgrel=0
+pkgdesc="Daemon for notifications in LXQt."
+url="http://lxqt.org"
+arch="all"
+license="LGPL-2.1+"
+depends=""
+depends_dev=""
+makedepends="cmake extra-cmake-modules liblxqt-dev>=0.12.0 lxqt-build-tools qt5-qttools-dev kwindowsystem-dev $depends_dev"
+install=""
+source="https://github.com/lxde/lxqt-notificationd/releases/download/$pkgver/lxqt-notificationd-$pkgver.tar.xz"
+builddir="$srcdir/lxqt-notificationd-$pkgver"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ -DPULL_TRANSLATIONS=False \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="89243c011b8d5a96d3f407a71d14a8c6c8792cded1d92dd442991b1acf73deb884e0ef668a2806e0348f95affbb408f913e61355c84ba406d20f43fedaf2285a lxqt-notificationd-0.12.0.tar.xz"