summaryrefslogtreecommitdiff
path: root/user/mosquitto/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/mosquitto/APKBUILD')
-rw-r--r--user/mosquitto/APKBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/user/mosquitto/APKBUILD b/user/mosquitto/APKBUILD
index 71e1fb99c..317988a70 100644
--- a/user/mosquitto/APKBUILD
+++ b/user/mosquitto/APKBUILD
@@ -2,21 +2,20 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=mosquitto
-pkgver=1.6.10
+pkgver=2.0.14
pkgrel=0
pkgdesc="An Open Source MQTT Broker"
url="https://mosquitto.org/"
arch="all"
license="EPL-1.0 AND EDL-1.0 AND MIT AND BSD-3-Clause"
depends=""
-checkdepends="python3"
-makedepends="c-ares-dev openssl-dev util-linux-dev"
+checkdepends="python3 ca-certificates cunit-dev"
+makedepends="c-ares-dev openssl-dev util-linux-dev cjson-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-openrc
$pkgname-clients"
install="$pkgname.pre-install"
source="http://mosquitto.org/files/source/$pkgname-$pkgver.tar.gz
mosquitto.initd
- disable-flaky-test.patch
openrc-conf.patch
"
@@ -46,9 +45,17 @@ build() {
}
check() {
- # Unit tests require cunit, so skip them.
- make -j1 -C test/broker test
- make -j1 -C test/lib test
+ # Explicitly disable tests, instead of enabling only good ones.
+ sed -i test/broker/test.py \
+ -e '/08-ssl-connect-cert-auth-without.py/d' `#687` \
+ ;
+ sed -i test/lib/test.py \
+ -e '/02-subscribe-qos1.py/d' \
+ ;
+ sed -i test/client/Makefile \
+ -e '/test.sh/d' \
+ ;
+ make ptest
}
package() {
@@ -73,7 +80,6 @@ clients() {
mv "$pkgdir"/usr/bin/mosquitto_[ps]ub "$subpkgdir"/usr/bin/
}
-sha512sums="2050a7a7af864057a177728f1cab9f6db70d6d1ea609d90c637723c2c9cfc9716429739302abd6742bde932716fae340854fff35956693dfee4ef31ce7b04a25 mosquitto-1.6.10.tar.gz
+sha512sums="a9e4f41b9af679b30318570e86a465546024651373df10e3b132f4593b89d22d0dbac01bb7371a57132ba030a2e73971c612acb5c9ac12f5ccd06aa38d9444c2 mosquitto-2.0.14.tar.gz
681fddc737b3ef3e6c052f0c854a730df290352640a18a63e23ef83d14c425558aff87805d1eb95e44de101b5df48872173af9f5414464ffa8cf727ea2c0491e mosquitto.initd
-daaae48d49e49a9911f152dfc80f67f2371ad62647d3324b360eb83f816c0898469c135209ddb69e80a29b313bbe3b6ee11463955c97a44584921c13832a07be disable-flaky-test.patch
b07f9bec2751ab32c43f53e74d8fca18dbf2d7ce7f8fab562dbcf75de19609ba6219d735ac504697404e0ed36613a14074e3a19e735297195877798f778d337a openrc-conf.patch"