summaryrefslogtreecommitdiff
path: root/user/mtdev
diff options
context:
space:
mode:
Diffstat (limited to 'user/mtdev')
-rw-r--r--user/mtdev/APKBUILD17
-rw-r--r--user/mtdev/printf-format.patch19
2 files changed, 27 insertions, 9 deletions
diff --git a/user/mtdev/APKBUILD b/user/mtdev/APKBUILD
index 81300c4e2..18a1826f0 100644
--- a/user/mtdev/APKBUILD
+++ b/user/mtdev/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=mtdev
-pkgver=1.1.5
-pkgrel=3
+pkgver=1.1.6
+pkgrel=0
pkgdesc="Multitouch Protocol Translation Library"
url="http://bitmath.org/code/mtdev/"
arch="all"
@@ -11,16 +11,16 @@ depends=""
depends_dev="linux-headers"
makedepends="$depends_dev"
subpackages="$pkgname-dev"
-source="http://bitmath.org/code/mtdev/mtdev-$pkgver.tar.gz"
+source="http://bitmath.org/code/mtdev/mtdev-$pkgver.tar.gz
+ printf-format.patch
+ "
prepare() {
- cd "$builddir"
- update_config_sub
default_prepare
+ update_config_sub
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -33,12 +33,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
@@ -47,4 +45,5 @@ dev() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-sha512sums="f59f8cda9b81e17253ff2da93a14b6f8e48361aff890dd5d1bb89ca385d713c212f961ed34fc5b866affd83013530a036736faca071ec9a424091979a12c9208 mtdev-1.1.5.tar.gz"
+sha512sums="e643264baa880abfc31b53f8e8ed54fe1adea4bc110fab57d36be16caba84f970c09fc864244c64b0a76e85f5f021fd086c12f96badbd886da6ccf254ab678e9 mtdev-1.1.6.tar.gz
+5a429ab3f7773e86eafb5beaff466ca6e209a131bfc1fd633e3ba4bfdf92caadf5037a3e84efb512bdc12891b2cc44ebb61b826daf3e66a7735004cc1dcd2713 printf-format.patch"
diff --git a/user/mtdev/printf-format.patch b/user/mtdev/printf-format.patch
new file mode 100644
index 000000000..46d187f64
--- /dev/null
+++ b/user/mtdev/printf-format.patch
@@ -0,0 +1,19 @@
+--- mtdev-1.1.6/test/mtdev-test.c.old 2020-01-26 14:00:32.000000000 +0000
++++ mtdev-1.1.6/test/mtdev-test.c 2020-01-30 02:17:49.009346559 +0000
+@@ -31,6 +31,7 @@
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <stdint.h>
++#include <inttypes.h>
+
+ #ifndef input_event_sec
+ #define input_event_sec time.tv_sec
+@@ -56,7 +57,7 @@
+ mstime_t evtime = ev->input_event_usec / ms + ev->input_event_sec * ms;
+ if (ev->type == EV_ABS && ev->code == ABS_MT_SLOT)
+ slot = ev->value;
+- fprintf(stderr, "%012llx %02d %01d %04x %d\n",
++ fprintf(stderr, "%012"PRIx64" %02d %01d %04x %d\n",
+ evtime, slot, ev->type, ev->code, ev->value);
+ }
+