summaryrefslogtreecommitdiff
path: root/user/nasm
diff options
context:
space:
mode:
Diffstat (limited to 'user/nasm')
-rw-r--r--user/nasm/APKBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/user/nasm/APKBUILD b/user/nasm/APKBUILD
index 81aa6a996..4e73db97e 100644
--- a/user/nasm/APKBUILD
+++ b/user/nasm/APKBUILD
@@ -6,12 +6,13 @@ pkgdesc="80x86 assembler designed for portability and modularity"
url="https://www.nasm.us/"
arch="all"
license="BSD-2-Clause"
+depends=""
checkdepends="perl"
+makedepends=""
subpackages="$pkgname-doc"
source="https://www.nasm.us/pub/nasm/releasebuilds/$pkgver/$pkgname-$pkgver.tar.bz2"
build () {
- cd "$builddir"
export CFLAGS=
export CXXFLAGS=
./configure \
@@ -22,12 +23,10 @@ build () {
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}