summaryrefslogtreecommitdiff
path: root/user/perl-carp-clan/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/perl-carp-clan/APKBUILD')
-rw-r--r--user/perl-carp-clan/APKBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/user/perl-carp-clan/APKBUILD b/user/perl-carp-clan/APKBUILD
index 619aec72e..0a2586220 100644
--- a/user/perl-carp-clan/APKBUILD
+++ b/user/perl-carp-clan/APKBUILD
@@ -1,4 +1,4 @@
-# Contributor: Alyx Wolcott <alyx@leuhta.com>
+# Contributor: Alyx Wolcott <alyx@leuhta.com>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-carp-clan
pkgver=6.07
@@ -13,18 +13,15 @@ source="https://cpan.metacpan.org/authors/id/E/ET/ETHER/Carp-Clan-$pkgver.tar.gz
builddir="$srcdir/Carp-Clan-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}