summaryrefslogtreecommitdiff
path: root/user/perl-extutils-cchecker/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/perl-extutils-cchecker/APKBUILD')
-rw-r--r--user/perl-extutils-cchecker/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/user/perl-extutils-cchecker/APKBUILD b/user/perl-extutils-cchecker/APKBUILD
new file mode 100644
index 000000000..b0646acda
--- /dev/null
+++ b/user/perl-extutils-cchecker/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
+# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
+pkgname=perl-extutils-cchecker
+_pkgreal=ExtUtils-CChecker
+_author=PEVANS
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
+pkgver=0.11
+pkgrel=0
+pkgdesc="Configure-time utilities for checking C headers, libraries, or OS features"
+url="https://metacpan.org/pod/ExtUtils::CChecker"
+arch="all"
+license="GPL-1.0+ OR Artistic-1.0-Perl"
+depends="perl"
+checkdepends="perl-test-fatal"
+makedepends="perl-module-build"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ perl Build.PL --destdir="$pkgdir" --prefix="/usr" --installdirs="vendor"
+ ./Build
+}
+
+check() {
+ ./Build test
+}
+
+package() {
+ ./Build install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="4b638e5082443eafcf2f3586ec8ff20ee62b054f8bc24149dd7a2549f57ca748618f76c057f456eadca4e5c4099071ee2d1c8993a13e2f5ea8924cd92319dd8c ExtUtils-CChecker-0.11.tar.gz"