summaryrefslogtreecommitdiff
path: root/user/perl-test2-plugin-nowarnings
diff options
context:
space:
mode:
Diffstat (limited to 'user/perl-test2-plugin-nowarnings')
-rw-r--r--user/perl-test2-plugin-nowarnings/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/user/perl-test2-plugin-nowarnings/APKBUILD b/user/perl-test2-plugin-nowarnings/APKBUILD
new file mode 100644
index 000000000..a2f6d7726
--- /dev/null
+++ b/user/perl-test2-plugin-nowarnings/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
+# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
+pkgname=perl-test2-plugin-nowarnings
+_pkgreal=Test2-Plugin-NoWarnings
+_author=DROLSKY
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
+pkgver=0.09
+pkgrel=0
+pkgdesc="Plugin for ensuring that tests fail if they produce a warning"
+url="https://metacpan.org/pod/Test2::Plugin::NoWarnings"
+arch="all"
+license="Artistic-2.0"
+depends="perl perl-test2-suite"
+checkdepends="perl-ipc-run3"
+makedepends=""
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="3b93d6c4522e913c4bc9d589b650f784327bed1a36a0dc18943dd2ea34654215333753cb532d5ffff6f0ef0af9ce0859e9744637cff89a1a1a5b936149f9b455 Test2-Plugin-NoWarnings-0.09.tar.gz"