summaryrefslogtreecommitdiff
path: root/user/postgresql
diff options
context:
space:
mode:
Diffstat (limited to 'user/postgresql')
-rw-r--r--user/postgresql/APKBUILD16
-rw-r--r--user/postgresql/initdb.patch14
2 files changed, 4 insertions, 26 deletions
diff --git a/user/postgresql/APKBUILD b/user/postgresql/APKBUILD
index fef7c4ef2..8f7f21355 100644
--- a/user/postgresql/APKBUILD
+++ b/user/postgresql/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=postgresql
-pkgver=10.10
+pkgver=10.12
pkgrel=0
pkgdesc="Featureful object-relational database system (RDBMS)"
url="https://www.postgresql.org/"
@@ -22,7 +22,6 @@ subpackages="$pkgname-contrib $pkgname-dev $pkgname-doc libpq $pkgname-libs
$pkgname-plpython3 $pkgname-plpython3-contrib:plpython3_contrib"
install="$pkgname.pre-upgrade"
source="https://ftp.postgresql.org/pub/source/v$pkgver/$pkgname-$pkgver.tar.bz2
- initdb.patch
perl-rpath.patch
conf-unix_socket_directories.patch
disable-broken-tests.patch
@@ -62,9 +61,8 @@ source="https://ftp.postgresql.org/pub/source/v$pkgver/$pkgname-$pkgver.tar.bz2
prepare() {
default_prepare
- cd "$builddir"
- local file; for file in $pkgname.initd $pkgname.confd; do
+ for file in $pkgname.initd $pkgname.confd; do
sed "s|@VERSION@|${pkgver%.*}|" "$srcdir"/$file > $file
done
}
@@ -93,16 +91,12 @@ build() {
}
check() {
- cd "$builddir"
-
_run_tests src/test
_run_tests src/pl
_run_tests contrib
}
package() {
- cd "$builddir"
-
make DESTDIR="$pkgdir" install install-docs
cd "$pkgdir"
@@ -167,7 +161,6 @@ contrib() {
depends=""
cd "$builddir"
-
# Avoid installing plperl and plpython extensions, these will be
# installed into separate subpackages.
sed -Ei -e 's/(.*_plperl)/#\1/' \
@@ -250,14 +243,13 @@ _run_tests() {
}
_submv() {
- local path; for path in "$@"; do
+ for path in "$@"; do
mkdir -p "$subpkgdir/${path%/*}"
mv "$pkgdir"/$path "$subpkgdir"/${path%/*}/
done
}
-sha512sums="60cafe4b27a194949aff482dcce4fa096a9916f37205868437a32afb8964df71934b619a0b891fe85eb7c7f9b11775cffbbedca589e78feb6c4184eb224b48bc postgresql-10.10.tar.bz2
-1f8e7dc58f5b0a12427cf2fd904ffa898a34f23f3332c8382b94e0d991c007289e7913a69e04498f3d93fc5701855796c207b4b1cc4a0b366f586050124d7fcc initdb.patch
+sha512sums="6accc66cbbae811509095c33e8a8d17ddd11d9e307267312e3d09df90469db4700a5806166d66f25d77769d3ef88653c98dfc7d05dd053f10434b03e0a9e33b7 postgresql-10.12.tar.bz2
5f9d8bb4957194069d01af8ab3abc6d4d83a7e7f8bd7ebe1caae5361d621a3e58f91b14b952958138a794e0a80bc154fbb7e3e78d211e2a95b9b7901335de854 perl-rpath.patch
8439a6fdfdea0a4867daeb8bc23d6c825f30c00d91d4c39f48653f5ee77341f23282ce03a77aad94b5369700f11d2cb28d5aee360e59138352a9ab331a9f9d0f conf-unix_socket_directories.patch
1966b2a3971f56fbecd8daa45965236d487683e13300e5c000e595bbadbbe9d0e1301fbbfa034f452abe8a4e4a427781f772370b9ff392bb03fc11ee43c9dee7 disable-broken-tests.patch
diff --git a/user/postgresql/initdb.patch b/user/postgresql/initdb.patch
deleted file mode 100644
index 59a872a49..000000000
--- a/user/postgresql/initdb.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/src/bin/initdb/initdb.c b/src/bin/initdb/initdb.c
---- a/src/bin/initdb/initdb.c
-+++ b/src/bin/initdb/initdb.c
-@@ -3259,9 +3259,7 @@
- /* translator: This is a placeholder in a shell command. */
- appendPQExpBuffer(start_db_cmd, " -l %s start", _("logfile"));
-
-- printf(_("\nSuccess. You can now start the database server using:\n\n"
-- " %s\n\n"),
-- start_db_cmd->data);
-+ printf(_("\nSuccess.\n\n"));
-
- destroyPQExpBuffer(start_db_cmd);
-