summaryrefslogtreecommitdiff
path: root/user/protobuf
diff options
context:
space:
mode:
Diffstat (limited to 'user/protobuf')
-rw-r--r--user/protobuf/APKBUILD9
1 files changed, 2 insertions, 7 deletions
diff --git a/user/protobuf/APKBUILD b/user/protobuf/APKBUILD
index 9efc662a9..028164bd8 100644
--- a/user/protobuf/APKBUILD
+++ b/user/protobuf/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=protobuf
_gemname=google-protobuf
-pkgver=3.10.0
+pkgver=3.11.2
_tstver=1.8.1
pkgrel=0
pkgdesc="Library for extensible, efficient structure packing"
@@ -21,8 +21,6 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/google/$pkgname/archive/v$pk
prepare() {
default_prepare
-
- cd "$builddir"
./autogen.sh
# symlink tests to the test directory
@@ -33,7 +31,6 @@ prepare() {
build() {
# Build Protobuf
- cd "$builddir"
CXXFLAGS="$CXXFLAGS -fno-delete-null-pointer-checks" LDFLAGS="$LDFLAGS -latomic" \
./configure --prefix=/usr \
--sysconfdir=/etc \
@@ -69,7 +66,6 @@ build() {
}
check() {
- cd "$builddir"
make check
cd "$builddir"/ruby
rake test
@@ -78,7 +74,6 @@ check() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
@@ -116,5 +111,5 @@ vim() {
"$subpkgdir"/usr/share/vim/vimfiles/syntax/proto.vim
}
-sha512sums="0dcba6d21486fdc162f57119754b47b4a2fb605af878d5b96a32df55895321535cffb5b804566fd90ee7c36e20106d0cd4f5d9f3c652dc9c4dfca96be41a1977 protobuf-3.10.0.tar.gz
+sha512sums="8319c1e003e5fc64e91b512de016ec1cf10265b294d3b4beea60856beaeb02b4d7682343c74b2c12b0f6d4d6258451af9b9d72bcb4b495293b7637da21030c8f protobuf-3.11.2.tar.gz
e6283c667558e1fd6e49fa96e52af0e415a3c8037afe1d28b7ff1ec4c2ef8f49beb70a9327b7fc77eb4052a58c4ccad8b5260ec90e4bceeac7a46ff59c4369d7 googletest-1.8.1.tar.gz"