summaryrefslogtreecommitdiff
path: root/user/py3-cryptography
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-cryptography')
-rw-r--r--user/py3-cryptography/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/user/py3-cryptography/APKBUILD b/user/py3-cryptography/APKBUILD
index d1c6da05c..a2f3c0091 100644
--- a/user/py3-cryptography/APKBUILD
+++ b/user/py3-cryptography/APKBUILD
@@ -5,14 +5,16 @@ pkgname=py3-cryptography
_pkgname=${pkgname#py3-}
_p="${_pkgname#?}"
_p="${_pkgname%"$_p"}"
-pkgver=2.7
+pkgver=2.8
pkgrel=0
pkgdesc="A package which provides cryptographic recipes and primitives"
url="https://pypi.org/project/cryptography"
arch="all"
-options="!check" # tests want hypothesis; deep rabbit hole
+options="!check" # See checkdepends comment below.
license="Apache-2.0 OR BSD-3-Clause"
depends="python3 py3-cffi py3-asn1crypto py3-six"
+# requires unpackaged py3-cryptography_vectors which makes no sense to package
+#checkdepends="py3-attrs py3-hypothesis py3-pretend py3-pytest py3-tz"
makedepends="python3-dev libffi-dev openssl-dev"
subpackages=""
source="https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
@@ -22,9 +24,12 @@ build() {
python3 setup.py build
}
+check() {
+ python3 setup.py test
+}
+
package() {
- mkdir -p "$pkgdir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="fa420f44b038b6fe1983c6f2c6d830e2668017c26e1e125ad621e37ea627a927ffe64d0e987e0a26dcc260834f2ec817cccd22da03b892190f46cb6e8131a5a8 cryptography-2.7.tar.gz"
+sha512sums="bf3ca44123c693b0602be19445925f9efebd46c469909e47b7907d57141fb6bd99268c33e1fe3f42a08ab8b4edd4f98f21b6a682f530352313334dfd31ba91e7 cryptography-2.8.tar.gz"