summaryrefslogtreecommitdiff
path: root/user/py3-html5lib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-html5lib/APKBUILD')
-rw-r--r--user/py3-html5lib/APKBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/user/py3-html5lib/APKBUILD b/user/py3-html5lib/APKBUILD
index 898efe4f1..f4f5f7781 100644
--- a/user/py3-html5lib/APKBUILD
+++ b/user/py3-html5lib/APKBUILD
@@ -9,27 +9,27 @@ pkgrel=0
pkgdesc="HTML parser based on the WHATWG HTML specification"
url="https://pypi.python.org/pypi/html5lib"
arch="noarch"
+options="!check" # https://github.com/html5lib/html5lib-python/issues/433
license="MIT"
depends="python3 py3-six py3-webencodings"
-makedepends="python3-dev"
checkdepends="py3-pytest py3-mock py3-pytest-expect"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+makedepends="python3-dev"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz
+ pytest.patch
+ "
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
pytest
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
-
}
-sha512sums="35939b4450893864da04e735ee5e0addacf1dd34bae6a6909c76572abf6bfded446a78a713dfde91c1485ba45867d7abeb6a45cf0545c16ea968707be7de5dd2 py3-html5lib-1.0.1.tar.gz"
+sha512sums="35939b4450893864da04e735ee5e0addacf1dd34bae6a6909c76572abf6bfded446a78a713dfde91c1485ba45867d7abeb6a45cf0545c16ea968707be7de5dd2 py3-html5lib-1.0.1.tar.gz
+89be46d5eb7b4a9ada22fa30576ae4f92d705b77988a47d52cbd876bf36240b461e7a0057c865a6b1798a3117343159ecbca43faf5316b446e5a80b8486a7e86 pytest.patch"