summaryrefslogtreecommitdiff
path: root/user/py3-olefile/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-olefile/APKBUILD')
-rw-r--r--user/py3-olefile/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/user/py3-olefile/APKBUILD b/user/py3-olefile/APKBUILD
new file mode 100644
index 000000000..4709626ae
--- /dev/null
+++ b/user/py3-olefile/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-olefile
+_pkgname=olefile
+pkgver=0.44
+pkgrel=0
+pkgdesc="A Python module to read/write MS OLE2 files"
+url="https://pypi.python.org/pypi/olefile"
+arch="noarch"
+license="Custom"
+depends="python3"
+makedepends="py3-setuptools python3-dev"
+install=""
+giturl="https://github.com/decalage2/olefile"
+verbase="$pkgver"
+reporev="v$pkgver"
+# The downloads from GitHub are missing the test files
+source="https://dev.sick.bike/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ PYTHONPATH="build/lib" python3 tests/test_olefile.py
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="bece8b040cb3572c1fa2536a21c1de4c05e560b641e1c6e4bf66772135c43d29e06c7fc47d6c07d3c351b1f741f49c63201657634c33e9124de892e9a0cc053f py3-olefile-0.44.tar.gz"