summaryrefslogtreecommitdiff
path: root/user/py3-setuptools/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-setuptools/APKBUILD')
-rw-r--r--user/py3-setuptools/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/user/py3-setuptools/APKBUILD b/user/py3-setuptools/APKBUILD
index ba5e1aebf..ed0269de7 100644
--- a/user/py3-setuptools/APKBUILD
+++ b/user/py3-setuptools/APKBUILD
@@ -2,10 +2,10 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-setuptools
_pkgname=setuptools
-pkgver=38.4.0
+pkgver=39.0.1
pkgrel=1
pkgdesc="A collection of enhancements to the Python distutils"
-url="http://pypi.python.org/pypi/setuptools"
+url="http://pypi.python.org/project/setuptools"
arch="noarch"
license="MIT"
depends="python3"
@@ -15,7 +15,8 @@ options="!check" # Circular dependency with py3-tox. Passes on x86_64
subpackages="py3-easy_install:easy_install"
# Note: PyPI download is missing tests/requirements.txt
source="$pkgname-$pkgver.tar.gz::https://github.com/pypa/$_pkgname/archive/v$pkgver.tar.gz
- pythonpath.patch"
+ pythonpath.patch
+ update-wheel-tests.patch"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -41,5 +42,6 @@ easy_install() {
mv "$pkgdir"/usr/bin/easy_install* "$subpkgdir/usr/bin"
}
-sha512sums="81903ee7ecb19715bbafe7b4e6878d3af5f801a9ff3334e82a599a81a8e6430443c4b765180c53c3c9cdcea338b3fff0bdf26245bc9d2da7d5d41b745de73a24 py3-setuptools-38.4.0.tar.gz
-0c80433534dbb715829f48713690a72a68f6cb7e337215c9aa507df0fbb2a2a242f54d42fab848c6f03729f155dfe0ccb819a6f5d5230e2195e94e20094eec0b pythonpath.patch"
+sha512sums="34df8f10e89825975c82059c759690a2cc1486fc84c71a76875b92c2452529fbdd628e11e3043e479ea3f031af18b37a37b86d2a8d2505c300188eccdc109332 py3-setuptools-39.0.1.tar.gz
+0c80433534dbb715829f48713690a72a68f6cb7e337215c9aa507df0fbb2a2a242f54d42fab848c6f03729f155dfe0ccb819a6f5d5230e2195e94e20094eec0b pythonpath.patch
+5262d1dcdbf8ab40eb4e9fde3e8496e6b4e9809d6056e6069fc11ef5390e064dfef9f7eccec3452e7566b88ab861bf544b57dce249c4291142f307bd6465e45a update-wheel-tests.patch"