summaryrefslogtreecommitdiff
path: root/user/py3-sphinxcontrib-applehelp
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-sphinxcontrib-applehelp')
-rw-r--r--user/py3-sphinxcontrib-applehelp/APKBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/user/py3-sphinxcontrib-applehelp/APKBUILD b/user/py3-sphinxcontrib-applehelp/APKBUILD
index 26010c36a..eebdeb272 100644
--- a/user/py3-sphinxcontrib-applehelp/APKBUILD
+++ b/user/py3-sphinxcontrib-applehelp/APKBUILD
@@ -12,23 +12,20 @@ arch="noarch"
options="!check" # Cyclic dependency with sphinx
license="BSD-2-Clause"
depends="python3"
-makedepends="python3-dev"
checkdepends="py3-sphinx py3-pytest"
+makedepends="python3-dev"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
PYTHONWARNINGS="all,ignore::DeprecationWarning:docutils.io" pytest --durations 25
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}