summaryrefslogtreecommitdiff
path: root/user/py3-taillight/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-taillight/APKBUILD')
-rw-r--r--user/py3-taillight/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/user/py3-taillight/APKBUILD b/user/py3-taillight/APKBUILD
new file mode 100644
index 000000000..66058e581
--- /dev/null
+++ b/user/py3-taillight/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-taillight
+_pkgname=taillight
+pkgver=0.3b4
+pkgrel=0
+pkgdesc="Lightweight, thread-safe signal/slots system with priorities"
+url="https://github.com/Elizafox/taillight"
+arch="noarch"
+license="WTFPL OR LPRAB"
+depends="python3"
+makedepends=""
+# PyPI download doesn't include tests/
+source="https://dev.sick.bike/dist/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 -m unittest discover -s tests
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="d54e2006d690b87ec7b96975c7d68f5954df993ffd3735100bcff91f3410f33a34b3a07fe22bb40aaad7364d63180b441302b171e52c1345cd90c709749a7bc8 py3-taillight-0.3b4.tar.gz"