summaryrefslogtreecommitdiff
path: root/user/qt5-qtdeclarative/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/qt5-qtdeclarative/APKBUILD')
-rw-r--r--user/qt5-qtdeclarative/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/user/qt5-qtdeclarative/APKBUILD b/user/qt5-qtdeclarative/APKBUILD
new file mode 100644
index 000000000..7f4e9c166
--- /dev/null
+++ b/user/qt5-qtdeclarative/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=qt5-qtdeclarative
+_pkgname=${pkgname/qt5-/}-opensource-src
+pkgver=5.9.6
+pkgrel=1
+pkgdesc="Qt 5 - Qt Declarative and Qt Quick 2"
+url="https://qt.io/"
+arch="all"
+license="LGPL-2.0 with exceptions OR GPL-3.0 with exceptions"
+makedepends="qt5-qtbase-dev libexecinfo-dev"
+subpackages="$pkgname-dev"
+source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz
+ add-execinfo.patch"
+
+_qt5_prefix=/usr/lib/qt5
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ qmake && make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make install INSTALL_ROOT="$pkgdir"
+
+ mkdir -p "$pkgdir"/usr/bin/
+ for i in "$pkgdir"/$_qt5_prefix/bin/*; do
+ ln -s ../lib/qt5/bin/${i##*/} "$pkgdir"/usr/bin/${i##*/}
+ done
+}
+
+sha512sums="1fc7a542c60e8c13ba9b791d7b83a916fc1ffb1d3ab505405055a13d597a2c406f29bbd9309603af5bf56492874efeee33ab0128af1fa44866d66d689147ac39 qtdeclarative-opensource-src-5.9.6.tar.xz
+065ab2440fd0a81e76fe8873b0991929fad3d4189c8938e0205e94478a6cdce81ef710e3bad19cd5ca0b5ea0f8b3cd1b366969ddede51070496d1d02ace59220 add-execinfo.patch"