summaryrefslogtreecommitdiff
path: root/user/scrot/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/scrot/APKBUILD')
-rw-r--r--user/scrot/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/user/scrot/APKBUILD b/user/scrot/APKBUILD
new file mode 100644
index 000000000..e9828b5ad
--- /dev/null
+++ b/user/scrot/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Nathan <ndowens@artixlinux.org>
+# Maintainer: Nathan <ndowens@artixlinux.org>
+pkgname=scrot
+pkgver=1.4
+pkgrel=0
+pkgdesc="Simple command-line screenshot utility for X"
+options="!check" # No testsuite
+url="https://github.com/resurrecting-open-source-projects/scrot"
+arch="all"
+license="MIT"
+depends=""
+makedepends="giblib-dev imlib2-dev libx11-dev libxfixes-dev libxcomposite-dev
+ automake libtool autoconf autoconf-archive sed"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/resurrecting-open-source-projects/scrot/archive/$pkgver/$pkgname-$pkgver.tar.gz
+ 0001-remove-ax-forbid.patch
+ config.h"
+
+prepare() {
+ default_prepare
+ autoreconf -fiv
+}
+
+build() {
+ sed -ie '2531d' configure
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ cp $srcdir/config.h src/scrot_config.h
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" docsdir=/usr/share/doc/scrot install
+}
+
+sha512sums="8423e7b2658f3e0ccf30f61e122016469226328adf8b1e511aeb031dd2655ae66582651e2d046c7c35d23efb98656369a02b59e711980481ddc4db24c299ee11 scrot-1.4.tar.gz
+ca7a40345b031c84ccc083202184dbff2418feb97472aca9fd441ba21501608562bdda061283db7793ad07a6d80e302c8f15a2819ac20dff8b741c6c539cbcd2 0001-remove-ax-forbid.patch
+95429feb7c107c5adeadf33b5a3e3ff9dc4fb95f0d58f92c6a8de27d776a07256fa9f1825896d569eb32beb77300f46995dcafd1359f305d22861eb5748de84a config.h"