summaryrefslogtreecommitdiff
path: root/user/shunit2
diff options
context:
space:
mode:
Diffstat (limited to 'user/shunit2')
-rw-r--r--user/shunit2/APKBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/user/shunit2/APKBUILD b/user/shunit2/APKBUILD
index baa658cf8..499f9a53e 100644
--- a/user/shunit2/APKBUILD
+++ b/user/shunit2/APKBUILD
@@ -8,23 +8,18 @@ url="https://github.com/kward/shunit2"
arch="noarch"
license="Apache-2.0"
depends="/bin/sh"
-makedepends=""
checkdepends="cmd:which bash dash zsh"
+makedepends=""
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/kward/shunit2/archive/v$pkgver.tar.gz
- dash-negative-lineno.patch"
-
-build() {
- cd "$builddir"
-}
+ dash-negative-lineno.patch
+ "
check() {
- cd "$builddir"
./test_runner
}
package() {
- cd "$builddir"
install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
install -Dm644 "doc/$pkgname.txt" "$pkgdir/usr/share/doc/$pkgname/$pkgname.rst"
}