summaryrefslogtreecommitdiff
path: root/user/spack/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/spack/APKBUILD')
-rw-r--r--user/spack/APKBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/user/spack/APKBUILD b/user/spack/APKBUILD
index 5f696e7a1..247f545e4 100644
--- a/user/spack/APKBUILD
+++ b/user/spack/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Zach van Rijn <me@zv.io>
# Maintainer: Zach van Rijn <me@zv.io>
pkgname=spack
-pkgver=0.21.0_p1
-pkgrel=5
+pkgver=0.23.0_p1
+pkgrel=0
pkgdesc="A flexible package manager for supercomputers."
url="https://spack.io/"
arch="all"
@@ -17,7 +17,6 @@ subpackages=""
# https://git.adelielinux.org/adelie/docs/-/wikis/Developer-Resources/Maintaining-Spack
source="https://git.adelielinux.org/adelie/$pkgname/-/archive/adelie-v$pkgver/$pkgname-adelie-v$pkgver.tar.bz2
clingo-explicit-libatomic.patch
- archspec-fix-cpu-family-detection.patch
openssl-explicit-linux-headers.patch
default-no-buildcache.patch
@@ -41,13 +40,24 @@ prepare()
check() {
##
+ # This is to prevent warnings about "Multiple definitions of compiler"
+ # in the event that 'ccache' is present and symlinked at /usr/local.
+ #
+ export PATH=/usr/sbin:/usr/bin:/sbin:/bin;
+
+ ##
# On first run, Spack >=0.17.0 will bootstrap "clingo",
# Spack's new "concretizer". The output from this process
# is not kept, however it demonstrates Spack's functionality.
+ #
+ # The '--deprecated' flag is to prevent an interactive prompt
+ # warning about "deprecated" packages and/or versions. Order
+ # is important; it must come after the 'install' verb.
+ #
export SPACK_DISABLE_LOCAL_CONFIG=true
export SPACK_USER_CONFIG_PATH=${builddir}/tmp
export SPACK_USER_CACHE_PATH=${builddir}/tmp
- bin/spack --debug install zlib
+ bin/spack --debug install --deprecated zlib
rm -fr var/spack/cache
rm -fr etc/spack/linux # caches compilers.yaml
@@ -67,9 +77,8 @@ package() {
install -D -m644 "${srcdir}"/config.yaml "$pkgdir"/etc/spack/config.yaml;
}
-sha512sums="85ae21de1f6c3d6eb3d3f0edc878820f17bae27236ea89eae0f733fa178eff25da41264960a492a2f34e03bd4f668ba1a2cfc395a814693c23f83b4ac2a80985 spack-adelie-v0.21.0_p1.tar.bz2
-30f6d193971bc6f2941141d0da50d339c459f2b9c6157cc2659a589bd2b546fba35d580cad79dd1bc74bcd9de7db31bc937418598d73b68c69876fee6a1c5c73 clingo-explicit-libatomic.patch
-a6503238d116b74ff9c4ecd08a984df90ce02f95c3e10e907481d99917c73339db1cc49f2b473a37875b92a9a6607cac72057c0a7b3d9a57d44c89ebe0ad3915 archspec-fix-cpu-family-detection.patch
+sha512sums="c40eb2ce32a7a432474c76ec76cda3a2830b7e9668d1dd76bf491d09d4bea6902e24f1fbff3c39ac67d2c0dd1f89560662a2828f9516ed99df8dc8bbd01afe6d spack-adelie-v0.23.0_p1.tar.bz2
+a84df22016109bb8d86b5215b698251a5b10873042361c8bab79e4235e00f381a2d66cbfd84ce6b7933125971f3248008124ef7f7ad85451bf72b815c5b56aa0 clingo-explicit-libatomic.patch
8ded405082eec192187fb72896c68200985ee1226b2ef7da19ab43f31138972d5b4000cf997cb6e22664a7c100b52b842df07c44e188f87d4250f698d1885ea6 openssl-explicit-linux-headers.patch
eec3e7dd818c39daea7b8d63b04a6c71d9eb3af32dd899cddc3642152252f4e2eebfd53c3c95365117f9a4826f6f29553f44373948e5c474388021302c8a5ce9 default-no-buildcache.patch
eb09ce82d2c5c63c2cc63b2f82db2888f15ce82100311614f5a73773be2f605337811c4580e0d4eb2f87b730e7ce4afa6dcdc3f3f52321f63a29a2ad533ea5d4 default-adelie-upstream-git.patch