summaryrefslogtreecommitdiff
path: root/user/spice-gtk
diff options
context:
space:
mode:
Diffstat (limited to 'user/spice-gtk')
-rw-r--r--user/spice-gtk/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/user/spice-gtk/APKBUILD b/user/spice-gtk/APKBUILD
index fb44cc0ec..e8a558036 100644
--- a/user/spice-gtk/APKBUILD
+++ b/user/spice-gtk/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=spice-gtk
pkgver=0.38
-pkgrel=0
+pkgrel=1
pkgdesc="A GTK+ widget for SPICE clients"
url="https://www.spice-space.org/"
arch="all"
@@ -13,7 +13,7 @@ depends="gst-plugins-good"
depends_dev="gobject-introspection-dev gtk+3.0-dev"
makedepends="$depends_dev acl-dev bash cyrus-sasl-dev eudev-dev
gst-plugins-base-dev gstreamer-dev gstreamer-tools gtk-doc
- json-glib-dev libjpeg-turbo-dev libucontext-dev
+ json-glib-dev libjpeg-turbo-dev
libxrandr-dev lz4-dev meson openssl-dev opus-dev polkit-dev
py3-pyparsing py3-six spice-protocol
zlib-dev"
@@ -24,8 +24,6 @@ source="https://www.spice-space.org/download/gtk/$pkgname-$pkgver.tar.xz
"
build() {
- export CFLAGS="$CFLAGS -lucontext"
-
# Note: pulseaudio support is disabled because it's deprecated.
# Audio is still supported through gstreamer.
#
@@ -41,6 +39,7 @@ build() {
-Dcelt051=disabled \
-Dpulse=disabled \
-Dusbredir=disabled \
+ -Dcoroutine=gthread \
. output
ninja -C output
}