summaryrefslogtreecommitdiff
path: root/user/wf-shell/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/wf-shell/APKBUILD')
-rw-r--r--user/wf-shell/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/user/wf-shell/APKBUILD b/user/wf-shell/APKBUILD
new file mode 100644
index 000000000..309aceafe
--- /dev/null
+++ b/user/wf-shell/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=wf-shell
+pkgver=0.9.0
+pkgrel=0
+pkgdesc="A GTK3-based panel for Wayfire"
+url="https://wayfire.org/"
+arch="all"
+license="MIT"
+depends=""
+makedepends="alsa-lib-dev gtk-layer-shell-dev gtkmm+3.0-dev libdbusmenu-dev
+ meson pulseaudio-dev wayfire-dev wayland-dev wayland-protocols"
+subpackages="$pkgname-dev $pkgname-doc"
+install_if="wayfire=$pkgver" # Wayfire wants this, but this needs Wayfire to build.
+source="https://github.com/WayfireWM/wf-shell/releases/download/v$pkgver/wf-shell-$pkgver.tar.xz"
+
+build() {
+ meson setup \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ --wrap-mode=nofallback \
+ . output
+ meson compile -C output
+}
+
+check() {
+ meson test -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C output
+}
+
+sha512sums="dceb0234302ceb51ac23576752d65cf122755bd044bc98e4ca92e0b8e6715063cdebdf35e82e5dc033effc288228622886e1a0e25b4bd788f6d32f8b189c1cfe wf-shell-0.9.0.tar.xz"