summaryrefslogtreecommitdiff
path: root/user/wine/rpath.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/wine/rpath.patch')
-rw-r--r--user/wine/rpath.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/user/wine/rpath.patch b/user/wine/rpath.patch
new file mode 100644
index 000000000..9f65cf034
--- /dev/null
+++ b/user/wine/rpath.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -859,6 +859,9 @@ case $host_os in
+ AC_SUBST(LIBWINE_SHAREDLIB,"libwine.so.$libwine_version")
+ AC_SUBST(LIBWINE_DEPENDS,"wine.map")
+ TOP_INSTALL_LIB="$TOP_INSTALL_LIB libs/wine/libwine.so.$libwine_version libs/wine/libwine.so.$libwine_soversion"
++
++ # do this at the end because it needs double dollar for makefile
++ WINE_TRY_CFLAGS([-Wl,-rpath,\\\$ORIGIN],[UNIXLDFLAGS="$UNIXLDFLAGS '-Wl,-rpath,\$\$ORIGIN'"])
+ ;;
+ esac