summaryrefslogtreecommitdiff
path: root/user/x265/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/x265/APKBUILD')
-rw-r--r--user/x265/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/user/x265/APKBUILD b/user/x265/APKBUILD
index 5ec4bbffa..0ca89487e 100644
--- a/user/x265/APKBUILD
+++ b/user/x265/APKBUILD
@@ -1,13 +1,14 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=x265
-pkgver=3.0
+pkgver=3.2.1
pkgrel=0
pkgdesc="Open Source H265/HEVC video encoder"
url="http://x265.org"
arch="all"
options="textrels"
license="GPL-2.0-only"
+depends=""
makedepends="cmake yasm" # 2.6+ will use nasm instead of yasm
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://bitbucket.org/multicoreware/$pkgname/downloads/${pkgname}_${pkgver}.tar.gz
@@ -17,7 +18,7 @@ builddir="$srcdir/${pkgname}_$pkgver"
build() {
cd "$builddir"/build/linux
- local cmake_opts=""
+ cmake_opts=""
case "$CARCH" in
# unfortunately, AltiVec code is very broken (more than 1000 errors)
ppc*) cmake_opts="-DENABLE_ALTIVEC=OFF -DCPU_POWER8=OFF";;
@@ -47,5 +48,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="bb7665194ddd4bccbb91c16337463ad4ef32111a1e7779e4cc16964df0992aa99e578cb74fef0edbf41119105e4085574247f60541b0558cc36730ea12d2c6ba x265-3.0.tar.gz
+sha512sums="5cb29b9d4475c1f686f6e31e47ccddde3db1639d5dcf9c058513389a9fdeb35a83b14e30e59498a76dec74bb0b410b6d8f5b1b45d18927be9811bb6a40d8d568 x265-3.2.1.tar.gz
ac3ecc613fe4da11672de8f397b5541fe2af29b7dd91a48859bfe8824934a5966c41ca30de242564c46f1a0cdd2a0da9331d9f547fc21120066fb3c45347c4c4 x265-unbreak-my-arm.patch"