summaryrefslogtreecommitdiff
path: root/user/xautolock/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/xautolock/APKBUILD')
-rw-r--r--user/xautolock/APKBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/user/xautolock/APKBUILD b/user/xautolock/APKBUILD
index 71fd17994..a614dfb54 100644
--- a/user/xautolock/APKBUILD
+++ b/user/xautolock/APKBUILD
@@ -1,29 +1,27 @@
-# Contributor: Johannes Matheis <jomat+alpinebuild@jmt.gr>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=xautolock
pkgver=2.2
pkgrel=4
pkgdesc="An automatic X screen-locker/screen-saver"
url="http://ibiblio.org/pub/Linux/X11/screensavers/"
-arch="all" # this might not build on aarch64? removed from alpine commit
-license="GPL-2.0"
-options="!check" # This package has no testsuite
+arch="all"
+options="!check" # This package has no test suite.
+license="GPL-2.0-only"
depends=""
makedepends="$depends_dev imake xorg-server-dev libxscrnsaver-dev xorg-cf-files"
subpackages="$pkgname-doc"
source="https://www.ibiblio.org/pub/linux/X11/screensavers/xautolock-$pkgver.tgz
- processwait.patch"
+ processwait.patch
+ "
build() {
- cd "$builddir"
- xmkmf
- make
+ xmkmf
+ make
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
- make MANPATH=/usr/share/man DESTDIR="$pkgdir" install.man
+ make DESTDIR="$pkgdir" install
+ make MANPATH=/usr/share/man DESTDIR="$pkgdir" install.man
}
sha512sums="5f9dcc25cda706610e77a74235c4b421ca3a833d154b1a269057f0774579e1c6ec36fe0e5be5fadd6942ce8c1640a760f891397586b162e6024b524635153d04 xautolock-2.2.tgz