summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/accfft
diff options
context:
space:
mode:
authorMassimiliano Culpo <massimiliano.culpo@gmail.com>2018-02-23 23:29:12 +0100
committerGitHub <noreply@github.com>2018-02-23 23:29:12 +0100
commit990f178341506fea78e2d1906fd746d8d42b6c94 (patch)
tree28a4ad7cdeb1e0c08369c01bf4fa1fcd095b3792 /var/spack/repos/builtin/packages/accfft
parent9c7d4e34f72007f26f49f989ad989babbda29f13 (diff)
downloadspack-990f178341506fea78e2d1906fd746d8d42b6c94.tar.gz
spack-990f178341506fea78e2d1906fd746d8d42b6c94.tar.bz2
spack-990f178341506fea78e2d1906fd746d8d42b6c94.tar.xz
spack-990f178341506fea78e2d1906fd746d8d42b6c94.zip
accfft: added new package (#7213)
Diffstat (limited to 'var/spack/repos/builtin/packages/accfft')
-rw-r--r--var/spack/repos/builtin/packages/accfft/package.py66
1 files changed, 66 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/accfft/package.py b/var/spack/repos/builtin/packages/accfft/package.py
new file mode 100644
index 0000000000..ff13660ffa
--- /dev/null
+++ b/var/spack/repos/builtin/packages/accfft/package.py
@@ -0,0 +1,66 @@
+##############################################################################
+# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
+# Produced at the Lawrence Livermore National Laboratory.
+#
+# This file is part of Spack.
+# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
+# LLNL-CODE-647188
+#
+# For details, see https://github.com/spack/spack
+# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License (as
+# published by the Free Software Foundation) version 2.1, February 1999.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
+# conditions of the GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+##############################################################################
+from spack import *
+
+
+class Accfft(CMakePackage, CudaPackage):
+ """AccFFT extends existing FFT libraries for CUDA-enabled
+ Graphics Processing Units (GPUs) to distributed memory clusters
+ """
+
+ homepage = "http://accfft.org"
+ url = "https://github.com/amirgholami/accfft.git"
+
+ version('develop', git='https://github.com/amirgholami/accfft.git', branch='master')
+
+ variant('pnetcdf', default=True, description='Add support for parallel NetCDF')
+ variant('shared', default=True, description='Enables the build of shared libraries')
+
+ # See: http://accfft.org/articles/install/#installing-dependencies
+ depends_on('fftw+float+double~mpi+openmp')
+
+ depends_on('parallel-netcdf', when='+pnetcdf')
+
+ parallel = False
+
+ def cmake_args(self):
+ spec = self.spec
+ args = [
+ '-DFFTW_ROOT={0}'.format(spec['fftw'].prefix),
+ '-DFFTW_USE_STATIC_LIBS=false',
+ '-DBUILD_GPU={0}'.format('true' if '+cuda' in spec else 'false'),
+ '-DBUILD_SHARED={0}'.format(
+ 'true' if '+shared' in spec else 'false'
+ ),
+ ]
+
+ if '+cuda' in spec:
+ cuda_arch = [x for x in spec.variants['cuda_arch'].value if x]
+ if cuda_arch:
+ args.append('-DCUDA_NVCC_FLAGS={0}'.format(
+ ' '.join(self.cuda_flags(cuda_arch))
+ ))
+
+ return args