summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/adios
diff options
context:
space:
mode:
authorAdam J. Stewart <ajstewart426@gmail.com>2022-03-23 02:50:00 -0500
committerGitHub <noreply@github.com>2022-03-23 08:50:00 +0100
commit5df10c04cd4ffe223f346b8bd9e5cd80dedbfe34 (patch)
treeb8ef0badda8ff94202d35c5bebd80e3163d8cb70 /var/spack/repos/builtin/packages/adios
parent8f89932aad0bdba3e4ffad57e9973118f73a0bb6 (diff)
downloadspack-5df10c04cd4ffe223f346b8bd9e5cd80dedbfe34.tar.gz
spack-5df10c04cd4ffe223f346b8bd9e5cd80dedbfe34.tar.bz2
spack-5df10c04cd4ffe223f346b8bd9e5cd80dedbfe34.tar.xz
spack-5df10c04cd4ffe223f346b8bd9e5cd80dedbfe34.zip
Use stable URLs and `?full_index=1` for all github patches (#29239)
The number of commit characters in patch files fetched from GitHub can change, so we should use `full_index=1` to enforce full commit hashes (and a stable patch `sha256`). Similarly, URLs for branches like `master` don't give us stable patch files, because branches are moving targets. Use specific tags or commits for those. - [x] update all github patch URLs to use `full_index=1` - [x] don't use `master` or other branches for patches - [x] add an audit check and a test for `?full_index=1` Co-authored-by: Todd Gamblin <tgamblin@llnl.gov>
Diffstat (limited to 'var/spack/repos/builtin/packages/adios')
-rw-r--r--var/spack/repos/builtin/packages/adios/package.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/var/spack/repos/builtin/packages/adios/package.py b/var/spack/repos/builtin/packages/adios/package.py
index ffd1286128..d6c4d76702 100644
--- a/var/spack/repos/builtin/packages/adios/package.py
+++ b/var/spack/repos/builtin/packages/adios/package.py
@@ -106,8 +106,8 @@ class Adios(AutotoolsPackage):
patch('zfp051.patch', when='@1.11.0:1.13.1')
# Fix a bug in configure.ac that causes automake issues on RHEL 7.7
- patch('https://github.com/ornladios/ADIOS/pull/207.patch', when='@1.12.0: +mpi',
- sha256='01113e9efb929d71c28bf33cc8b7f215d85195ec700e99cb41164e2f8f830640')
+ patch('https://github.com/ornladios/ADIOS/pull/207.patch?full_index=1', when='@1.12.0: +mpi',
+ sha256='aea47e56013b57c2d5d36e23e0ae6010541c3333a84003784437768c2e350b05')
def validate(self, spec):
"""Checks if incompatible variants have been activated at the same time