summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/armadillo/package.py
diff options
context:
space:
mode:
authorTodd Gamblin <tgamblin@llnl.gov>2022-07-30 15:19:18 -0700
committerTodd Gamblin <tgamblin@llnl.gov>2022-07-31 13:29:20 -0700
commitf52f6e99dbf1131886a80112b8c79dfc414afb7c (patch)
tree05cb7d64b2395922f2f24683da49f472075be12c /var/spack/repos/builtin/packages/armadillo/package.py
parent549ba1ed32372c67fc57271cde3797d58b7dec6e (diff)
downloadspack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.gz
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.bz2
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.xz
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.zip
black: reformat entire repository with black
Diffstat (limited to 'var/spack/repos/builtin/packages/armadillo/package.py')
-rw-r--r--var/spack/repos/builtin/packages/armadillo/package.py73
1 files changed, 35 insertions, 38 deletions
diff --git a/var/spack/repos/builtin/packages/armadillo/package.py b/var/spack/repos/builtin/packages/armadillo/package.py
index d1052f51a3..3d19e472f1 100644
--- a/var/spack/repos/builtin/packages/armadillo/package.py
+++ b/var/spack/repos/builtin/packages/armadillo/package.py
@@ -14,66 +14,63 @@ class Armadillo(CMakePackage):
homepage = "http://arma.sourceforge.net/"
url = "http://sourceforge.net/projects/arma/files/armadillo-8.100.1.tar.xz"
- version('10.5.0', sha256='ea990c34dc6d70d7c95b4354d9f3b0819bde257dbb67796348e91e196082cb87')
- version('9.800.3', sha256='a481e1dc880b7cb352f8a28b67fe005dc1117d4341277f12999a2355d40d7599')
- version('8.100.1', sha256='54773f7d828bd3885c598f90122b530ded65d9b195c9034e082baea737cd138d')
- version('7.950.1', sha256='a32da32a0ea420b8397a53e4b40ed279c1a5fc791dd492a2ced81ffb14ad0d1b')
+ version("10.5.0", sha256="ea990c34dc6d70d7c95b4354d9f3b0819bde257dbb67796348e91e196082cb87")
+ version("9.800.3", sha256="a481e1dc880b7cb352f8a28b67fe005dc1117d4341277f12999a2355d40d7599")
+ version("8.100.1", sha256="54773f7d828bd3885c598f90122b530ded65d9b195c9034e082baea737cd138d")
+ version("7.950.1", sha256="a32da32a0ea420b8397a53e4b40ed279c1a5fc791dd492a2ced81ffb14ad0d1b")
- variant('hdf5', default=False, description='Include HDF5 support')
+ variant("hdf5", default=False, description="Include HDF5 support")
- depends_on('cmake@2.8.12:', type='build')
- depends_on('arpack-ng') # old arpack causes undefined symbols
- depends_on('blas')
- depends_on('lapack')
- depends_on('superlu@5.2:')
- depends_on('hdf5', when='+hdf5')
+ depends_on("cmake@2.8.12:", type="build")
+ depends_on("arpack-ng") # old arpack causes undefined symbols
+ depends_on("blas")
+ depends_on("lapack")
+ depends_on("superlu@5.2:")
+ depends_on("hdf5", when="+hdf5")
# Adds an `#undef linux` to prevent preprocessor expansion of include
# directories with `linux` in them getting transformed into a 1.
# E.g. `/path/linux-x86_64/dir` -> `/path/1-x86_64/dir` if/when a linux
# platform's compiler is adding `#define linux 1`.
- patch('undef_linux.patch', when='platform=linux')
+ patch("undef_linux.patch", when="platform=linux")
def patch(self):
# Do not include Find{BLAS_type} because we are specifying the
# BLAS/LAPACK libraries explicitly.
- filter_file(r'include(ARMA_FindMKL)',
- '#include(ARMA_FindMKL)',
- 'CMakeLists.txt',
- string=True)
- filter_file(r'include(ARMA_FindOpenBLAS)',
- '#include(ARMA_FindOpenBLAS)',
- 'CMakeLists.txt',
- string=True)
- filter_file(r'include(ARMA_FindATLAS)',
- '#include(ARMA_FindATLAS)',
- 'CMakeLists.txt',
- string=True)
+ filter_file(
+ r"include(ARMA_FindMKL)", "#include(ARMA_FindMKL)", "CMakeLists.txt", string=True
+ )
+ filter_file(
+ r"include(ARMA_FindOpenBLAS)",
+ "#include(ARMA_FindOpenBLAS)",
+ "CMakeLists.txt",
+ string=True,
+ )
+ filter_file(
+ r"include(ARMA_FindATLAS)", "#include(ARMA_FindATLAS)", "CMakeLists.txt", string=True
+ )
# Comment out deprecated call to GET_FILENAME_COMPONENT. This allows
# armadillo to be built with MKL.
- with working_dir(join_path(self.stage.source_path,
- 'cmake_aux', 'Modules')):
- filter_file('GET_FILENAME_COMPONENT',
- '#GET_FILENAME_COMPONENT',
- 'ARMA_FindBLAS.cmake')
- filter_file('GET_FILENAME_COMPONENT',
- '#GET_FILENAME_COMPONENT',
- 'ARMA_FindLAPACK.cmake')
+ with working_dir(join_path(self.stage.source_path, "cmake_aux", "Modules")):
+ filter_file("GET_FILENAME_COMPONENT", "#GET_FILENAME_COMPONENT", "ARMA_FindBLAS.cmake")
+ filter_file(
+ "GET_FILENAME_COMPONENT", "#GET_FILENAME_COMPONENT", "ARMA_FindLAPACK.cmake"
+ )
def cmake_args(self):
spec = self.spec
return [
# ARPACK support
- '-DARPACK_LIBRARY={0}'.format(spec['arpack-ng'].libs.joined(";")),
+ "-DARPACK_LIBRARY={0}".format(spec["arpack-ng"].libs.joined(";")),
# BLAS support
- '-DBLAS_LIBRARY={0}'.format(spec['blas'].libs.joined(";")),
+ "-DBLAS_LIBRARY={0}".format(spec["blas"].libs.joined(";")),
# LAPACK support
- '-DLAPACK_LIBRARY={0}'.format(spec['lapack'].libs.joined(";")),
+ "-DLAPACK_LIBRARY={0}".format(spec["lapack"].libs.joined(";")),
# SuperLU support
- '-DSuperLU_INCLUDE_DIR={0}'.format(spec['superlu'].prefix.include),
- '-DSuperLU_LIBRARY={0}'.format(spec['superlu'].libs.joined(";")),
+ "-DSuperLU_INCLUDE_DIR={0}".format(spec["superlu"].prefix.include),
+ "-DSuperLU_LIBRARY={0}".format(spec["superlu"].libs.joined(";")),
# HDF5 support
- '-DDETECT_HDF5={0}'.format('ON' if '+hdf5' in spec else 'OFF')
+ "-DDETECT_HDF5={0}".format("ON" if "+hdf5" in spec else "OFF"),
]