summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/aspa/package.py
diff options
context:
space:
mode:
authorAkhil Reddy Patlolla <patlolla.akhil@gmail.com>2017-07-13 07:30:01 -0500
committerAdam J. Stewart <ajstewart426@gmail.com>2017-07-13 07:30:01 -0500
commit5ac2020c988d5c2b2f74328d141c872df656136b (patch)
treefd45c6fd683ae6ffdf7bea1c27bf8b1298811ed1 /var/spack/repos/builtin/packages/aspa/package.py
parenta95f40f18ef75ff3d78d43d15509e4ce018be89f (diff)
downloadspack-5ac2020c988d5c2b2f74328d141c872df656136b.tar.gz
spack-5ac2020c988d5c2b2f74328d141c872df656136b.tar.bz2
spack-5ac2020c988d5c2b2f74328d141c872df656136b.tar.xz
spack-5ac2020c988d5c2b2f74328d141c872df656136b.zip
Added ASPA Proxy App (#4743)
Diffstat (limited to 'var/spack/repos/builtin/packages/aspa/package.py')
-rw-r--r--var/spack/repos/builtin/packages/aspa/package.py72
1 files changed, 72 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/aspa/package.py b/var/spack/repos/builtin/packages/aspa/package.py
new file mode 100644
index 0000000000..863c8a2980
--- /dev/null
+++ b/var/spack/repos/builtin/packages/aspa/package.py
@@ -0,0 +1,72 @@
+##############################################################################
+# Copyright (c) 2013-2016, Lawrence Livermore National Security, LLC.
+# Produced at the Lawrence Livermore National Laboratory.
+#
+# This file is part of Spack.
+# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
+# LLNL-CODE-647188
+#
+# For details, see https://github.com/llnl/spack
+# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License (as
+# published by the Free Software Foundation) version 2.1, February 1999.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
+# conditions of the GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+##############################################################################
+from spack import *
+import glob
+
+
+class Aspa(MakefilePackage):
+ """A fundamental premise in ExMatEx is that scale-bridging performed in
+ heterogeneous MPMD materials science simulations will place important
+ demands upon the exascale ecosystem that need to be identified and
+ quantified.
+ tags = proxy-app
+ """
+ tags = ['proxy-app']
+ homepage = "http://www.exmatex.org/aspa.html"
+ url = "https://github.com/exmatex/ASPA/archive/master.tar.gz"
+
+ version('master', git='https://github.com/exmatex/ASPA.git',
+ description='master')
+ variant('mpi', default=True, description='Build with MPI Support')
+
+ depends_on('lapack')
+ depends_on('blas')
+ depends_on('mpi', when='+mpi')
+ depends_on('hdf5')
+
+ @property
+ def build_targets(self):
+ targets = [
+ '--directory=exec',
+ '--file=Makefile',
+ 'LIBS={0} {1} {2}'.format(self.spec['lapack'].libs.ld_flags,
+ self.spec['blas'].libs.ld_flags,
+ self.spec['hdf5'].libs.ld_flags),
+ 'CXX={0}'.format(self.spec['mpi'].mpicxx)
+ ]
+ return targets
+
+ def install(self, spec, prefix):
+ mkdirp(prefix.bin)
+ mkdirp(prefix.doc)
+ mkdirp(prefix.input)
+ install('exec/aspa', prefix.bin)
+ install('exec/README', prefix.doc)
+ install('exec/aspa.inp', prefix.input)
+ install('exec/kriging_model_centers.txt', prefix.input)
+ install('exec/point_data.txt', prefix.input)
+ install('exec/value_data.txt', prefix.input)
+ for files in glob.glob('doc/*.*'):
+ install(files, prefix.doc) \ No newline at end of file