summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/aspcud/package.py
diff options
context:
space:
mode:
authorGeoffrey Oxberry <goxberry@gmail.com>2018-02-27 04:16:40 -0800
committerMassimiliano Culpo <massimiliano.culpo@gmail.com>2018-02-27 13:16:40 +0100
commitae1759eb16f7ee7280fd8080a4782f5edf3cdb50 (patch)
tree8174f4a7aa15d5dd2baff1340436573ff2e74f33 /var/spack/repos/builtin/packages/aspcud/package.py
parent0c85aa09af3e2cf01b954ee4a0e27d3372814488 (diff)
downloadspack-ae1759eb16f7ee7280fd8080a4782f5edf3cdb50.tar.gz
spack-ae1759eb16f7ee7280fd8080a4782f5edf3cdb50.tar.bz2
spack-ae1759eb16f7ee7280fd8080a4782f5edf3cdb50.tar.xz
spack-ae1759eb16f7ee7280fd8080a4782f5edf3cdb50.zip
aspcud@1.9.4: new package (#7094)
Diffstat (limited to 'var/spack/repos/builtin/packages/aspcud/package.py')
-rw-r--r--var/spack/repos/builtin/packages/aspcud/package.py53
1 files changed, 53 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/aspcud/package.py b/var/spack/repos/builtin/packages/aspcud/package.py
new file mode 100644
index 0000000000..89f32c1a31
--- /dev/null
+++ b/var/spack/repos/builtin/packages/aspcud/package.py
@@ -0,0 +1,53 @@
+##############################################################################
+# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
+# Produced at the Lawrence Livermore National Laboratory.
+#
+# This file is part of Spack.
+# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
+# LLNL-CODE-647188
+#
+# For details, see https://github.com/spack/spack
+# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License (as
+# published by the Free Software Foundation) version 2.1, February 1999.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
+# conditions of the GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+##############################################################################
+from spack import *
+
+
+class Aspcud(CMakePackage):
+ """Aspcud: Package dependency solver
+
+ Aspcud is a solver for package dependencies. A package universe
+ and a request to install, remove, or upgrade packages have to
+ be encoded in the CUDF format. Such a CUDF document can then be
+ passed to aspcud along with an optimization criteria to obtain
+ a solution to the given package problem."""
+
+ homepage = "https://potassco.org/aspcud"
+ url = "https://github.com/potassco/aspcud/archive/v1.9.4.tar.gz"
+
+ version('1.9.4', '35e5c663a25912e4bdc94f168e827ed2')
+
+ depends_on('boost', type=('build'))
+ depends_on('cmake', type=('build'))
+ depends_on('re2c', type=('build'))
+ depends_on('clingo')
+
+ def cmake_args(self):
+ spec = self.spec
+ gringo_path = join_path(spec['clingo'].prefix.bin, 'gringo')
+ clasp_path = join_path(spec['clingo'].prefix.bin, 'clasp')
+ args = ['-DASPCUD_GRINGO_PATH={0}'.format(gringo_path),
+ '-DASPCUD_CLASP_PATH={0}'.format(clasp_path)]
+ return args