summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/aspect/package.py
diff options
context:
space:
mode:
authorTimo Heister <timo.heister@gmail.com>2018-06-13 15:42:29 -0400
committerAdam J. Stewart <ajstewart426@gmail.com>2018-06-13 14:42:29 -0500
commit758b813c3673ee74f0b23edb2a568d686107d507 (patch)
tree6d0f6e9cc0b9d30ac1b3c435760f92d50e03b88f /var/spack/repos/builtin/packages/aspect/package.py
parent664f03e32957041b28fc9b60e5cbb4729adc5cfc (diff)
downloadspack-758b813c3673ee74f0b23edb2a568d686107d507.tar.gz
spack-758b813c3673ee74f0b23edb2a568d686107d507.tar.bz2
spack-758b813c3673ee74f0b23edb2a568d686107d507.tar.xz
spack-758b813c3673ee74f0b23edb2a568d686107d507.zip
new package: ASPECT (#8459)
* add ASPECT package * add maintainer * simplify
Diffstat (limited to 'var/spack/repos/builtin/packages/aspect/package.py')
-rw-r--r--var/spack/repos/builtin/packages/aspect/package.py56
1 files changed, 56 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/aspect/package.py b/var/spack/repos/builtin/packages/aspect/package.py
new file mode 100644
index 0000000000..c55494f521
--- /dev/null
+++ b/var/spack/repos/builtin/packages/aspect/package.py
@@ -0,0 +1,56 @@
+##############################################################################
+# Copyright (c) 2013-2016, Lawrence Livermore National Security, LLC.
+# Produced at the Lawrence Livermore National Laboratory.
+#
+# This file is part of Spack.
+# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
+# LLNL-CODE-647188
+#
+# For details, see https://github.com/llnl/spack
+# Please also see the LICENSE file for our notice and the LGPL.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License (as
+# published by the Free Software Foundation) version 2.1, February 1999.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
+# conditions of the GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+##############################################################################
+from spack import *
+
+
+class Aspect(CMakePackage):
+ """Parallel, extendible finite element code to simulate convection in the
+ Earth's mantle and elsewhere."""
+
+ homepage = "https://aspect.geodynamics.org"
+ url = "https://github.com/geodynamics/aspect/releases/download/v2.0.0/aspect-2.0.0.tar.gz"
+
+ maintainers = ['tjhei']
+
+ version('2.0.0', 'dfecc571fb221f28a0800034cd29c95c')
+ version('develop', git='https://github.com/geodynamics/aspect.git', branch='master')
+
+ variant('build_type', default='Release',
+ description='The build type to build',
+ values=('Debug', 'Release'))
+ variant('gui', default=False, description='Enable the deal.II parameter GUI')
+ variant('fpe', default=False, description='Enable floating point exception checks')
+
+ depends_on('dealii+p4est+trilinos+mpi')
+ depends_on('dealii-parameter-gui', when='+gui')
+
+ def cmake_args(self):
+ return [
+ '-DASPECT_USE_FP_EXCEPTIONS=%s' %
+ ('ON' if '+fpe' in self.spec else 'OFF')
+ ]
+
+ def setup_environment(self, spack_env, run_env):
+ run_env.set('Aspect_DIR', self.prefix)