summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/atmi/package.py
diff options
context:
space:
mode:
authorsrekolam <67086238+srekolam@users.noreply.github.com>2020-08-12 17:36:35 -0700
committerGitHub <noreply@github.com>2020-08-12 19:36:35 -0500
commitad060c7870675ccb82c537fd983fd6bc28f7f4e8 (patch)
tree4a210580b58067986c492ed0304331c0c8bf9e50 /var/spack/repos/builtin/packages/atmi/package.py
parent25a0d89b58c977b4882da09b865b3e58191f5a71 (diff)
downloadspack-ad060c7870675ccb82c537fd983fd6bc28f7f4e8.tar.gz
spack-ad060c7870675ccb82c537fd983fd6bc28f7f4e8.tar.bz2
spack-ad060c7870675ccb82c537fd983fd6bc28f7f4e8.tar.xz
spack-ad060c7870675ccb82c537fd983fd6bc28f7f4e8.zip
Spack recipes for ROCm software components-Phase1 (#17422)
* Spack recipes for ROCm Stage 1 Build components * fix flake8 errors * fixes for flake8 errors * Add a patch for cmake 3.x suport * Fix rpath issue where hsa-rocr-dev does not allow it to be filled in by spack * Remove inherited cmake args from comgr * Make hsakmt-roct compile: no -Werror because with const cast in numa, and actually add the numa dependency * Remove redundant cmake args which is inherited * Fix some dependencies * Fix some python 2.x compatibilities * Add amd gpu targets to rocfft * Make comgr a link dep of rocm-dbgapi and remove redundant cmake args * Remove redundant cmake args * Remove more redundant cmake args * Final redundant args * Use cmake 3.x instead of a fixed version * Remove random variable * Use installed rocclr instead of nonexisting directory * Don't build outside the staging folder * Deploy some missing cmake target file * Formatting * Fix target list * Properly handle the rocclr dependency * Formatting * Fix vermin test * Make all 3.5.0 package depend exactly on eachother * Add a few missing link dependencies * Fix flake8 * Remove some other redundant flags * Add gcc install prefix for gcc builds of llvm-amdgpu * review changes for the spack recipes * Do not hard-code versions * Fix atmi install - no more relative rpaths outside of install directory (required patch) - fix build -> link dependencies - remove unused build dependency * Fix flake8 errors * Remove unused variable and make things python 2.x compatible * Fix flake8 * Move compiler config from rocfft -> hipcc * Remove redundant dependency on fftw-api * Remove redundant import * Avoid hitting the ROCM_PATH variable altogether with a patch; also just fill in all variables * Add missing deps z3, zlib and ncurses+termlib to llvm-amdgpu * Fix perl shebang and add dep * Fix typo and patch HIP_CLANG_ROOT detection in hip's cmake files * fixing build failure due z3 and adding zlib for rocgdb * new changes to add z3,curses dependency for llvm-amdgpu * fix flake8 error Co-authored-by: root <root@localhost.localdomain> Co-authored-by: Harmen Stoppels <harmenstoppels@gmail.com>
Diffstat (limited to 'var/spack/repos/builtin/packages/atmi/package.py')
-rw-r--r--var/spack/repos/builtin/packages/atmi/package.py42
1 files changed, 42 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/atmi/package.py b/var/spack/repos/builtin/packages/atmi/package.py
new file mode 100644
index 0000000000..c6063b3fde
--- /dev/null
+++ b/var/spack/repos/builtin/packages/atmi/package.py
@@ -0,0 +1,42 @@
+# Copyright 2013-2020 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
+#
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
+
+from spack import *
+
+
+class Atmi(CMakePackage):
+ """Asynchronous Task and Memory Interface, or ATMI, is a runtime framework
+ and programming model for heterogeneous CPU-GPU systems. It provides a
+ consistent, declarative API to create task graphs on CPUs and GPUs
+ (integrated and discrete)."""
+
+ homepage = "https://github.com/RadeonOpenCompute/atmi"
+ url = "https://github.com/RadeonOpenCompute/atmi/archive/rocm-3.5.0.tar.gz"
+
+ maintainers = ['srekolam', 'arjun-raj-kuppala']
+
+ version('3.5.0', sha256='3fb57d2e583fab82bd0582d0c2bccff059ca91122c18ac49a7770a8bb041a37b')
+
+ variant('build_type', default='Release', values=("Release", "Debug"), description='CMake build type')
+ depends_on('cmake@3:', type='build')
+ depends_on('libelf@0.8:', type='link', when='@3.5:')
+
+ for ver in ['3.5.0']:
+ depends_on('comgr@' + ver, type='link', when='@' + ver)
+ depends_on('hsa-rocr-dev@' + ver, type='link', when='@' + ver)
+
+ root_cmakelists_dir = 'src'
+
+ patch('0001-Remove-relative-link-paths-to-external-libraries.patch')
+
+ def cmake_args(self):
+ return [
+ '-DROCM_VERSION={0}'.format(self.spec.version)
+ ]
+
+ @run_after('install')
+ def install_stub(self):
+ install('include/atmi_interop_hsa.h', self.prefix.include)