summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/bigdft-chess/package.py
diff options
context:
space:
mode:
authorAshwin Kumar Karnad <46030335+iamashwin99@users.noreply.github.com>2023-04-21 03:18:11 +0200
committerGitHub <noreply@github.com>2023-04-20 18:18:11 -0700
commitbf04551bf57feb5bd503fe2389fc7eb254e581c4 (patch)
tree6c0fca64def93b52c392cae2d475a50d00286de6 /var/spack/repos/builtin/packages/bigdft-chess/package.py
parenta419ffcf501134faed24253ccc83e6c71f9659f9 (diff)
downloadspack-bf04551bf57feb5bd503fe2389fc7eb254e581c4.tar.gz
spack-bf04551bf57feb5bd503fe2389fc7eb254e581c4.tar.bz2
spack-bf04551bf57feb5bd503fe2389fc7eb254e581c4.tar.xz
spack-bf04551bf57feb5bd503fe2389fc7eb254e581c4.zip
Fix bigdft-suite compilation (#36612)
(from https://github.com/danielecesarini/spack/commit/d20f2841009eb037344e73516d38716769643e4b)
Diffstat (limited to 'var/spack/repos/builtin/packages/bigdft-chess/package.py')
-rw-r--r--var/spack/repos/builtin/packages/bigdft-chess/package.py17
1 files changed, 9 insertions, 8 deletions
diff --git a/var/spack/repos/builtin/packages/bigdft-chess/package.py b/var/spack/repos/builtin/packages/bigdft-chess/package.py
index 011dc18cba..c2731de7b5 100644
--- a/var/spack/repos/builtin/packages/bigdft-chess/package.py
+++ b/var/spack/repos/builtin/packages/bigdft-chess/package.py
@@ -25,6 +25,10 @@ class BigdftChess(AutotoolsPackage, CudaPackage):
variant("ntpoly", default=False, description="Option to use NTPoly")
# variant('minpack', default=False, description='Give the link-line for MINPACK')
+ depends_on("autoconf", type="build")
+ depends_on("automake", type="build")
+ depends_on("libtool", type="build")
+
depends_on("python@3.0:", type=("build", "run"))
depends_on("blas")
@@ -39,13 +43,7 @@ class BigdftChess(AutotoolsPackage, CudaPackage):
depends_on("bigdft-futile@{0}".format(vers), when="@{0}".format(vers))
depends_on("bigdft-atlab@{0}".format(vers), when="@{0}".format(vers))
- build_directory = "chess"
-
- def autoreconf(self, spec, prefix):
- autoreconf = which("autoreconf")
-
- with working_dir(self.build_directory):
- autoreconf("-fi")
+ configure_directory = "chess"
def configure_args(self):
spec = self.spec
@@ -61,12 +59,15 @@ class BigdftChess(AutotoolsPackage, CudaPackage):
linalg = []
if "+scalapack" in spec:
linalg.append(spec["scalapack"].libs.ld_flags)
+ linalg.append(spec["lapack"].libs.ld_flags)
+ linalg.append(spec["blas"].libs.ld_flags)
args = [
"FCFLAGS=%s" % " ".join(openmp_flag),
+ "LDFLAGS=%s" % " ".join(linalg),
"--with-ext-linalg=%s" % " ".join(linalg),
"--with-pyyaml-path=%s" % pyyaml,
- "--with-futile-libs=%s" % spec["bigdft-futile"].prefix.lib,
+ "--with-futile-libs=%s" % spec["bigdft-futile"].libs.ld_flags,
"--with-futile-incs=%s" % spec["bigdft-futile"].headers.include_flags,
"--with-moduledir=%s" % prefix.include,
"--prefix=%s" % prefix,