summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/bind9/package.py
diff options
context:
space:
mode:
authorTodd Gamblin <tgamblin@llnl.gov>2022-07-30 15:19:18 -0700
committerTodd Gamblin <tgamblin@llnl.gov>2022-07-31 13:29:20 -0700
commitf52f6e99dbf1131886a80112b8c79dfc414afb7c (patch)
tree05cb7d64b2395922f2f24683da49f472075be12c /var/spack/repos/builtin/packages/bind9/package.py
parent549ba1ed32372c67fc57271cde3797d58b7dec6e (diff)
downloadspack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.gz
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.bz2
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.xz
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.zip
black: reformat entire repository with black
Diffstat (limited to 'var/spack/repos/builtin/packages/bind9/package.py')
-rw-r--r--var/spack/repos/builtin/packages/bind9/package.py19
1 files changed, 11 insertions, 8 deletions
diff --git a/var/spack/repos/builtin/packages/bind9/package.py b/var/spack/repos/builtin/packages/bind9/package.py
index c507fa25b8..fc0272f10a 100644
--- a/var/spack/repos/builtin/packages/bind9/package.py
+++ b/var/spack/repos/builtin/packages/bind9/package.py
@@ -12,16 +12,19 @@ class Bind9(AutotoolsPackage):
"""
homepage = "https://github.com/isc-projects/bind9"
- url = "https://github.com/isc-projects/bind9/archive/v9_14_6.tar.gz"
+ url = "https://github.com/isc-projects/bind9/archive/v9_14_6.tar.gz"
- version('9_14_6', sha256='98be7a7b6d614b519f6c8d6ec7a8a39759ae9604d87228d9dc7c034471e5433e')
+ version("9_14_6", sha256="98be7a7b6d614b519f6c8d6ec7a8a39759ae9604d87228d9dc7c034471e5433e")
- depends_on('libuv', type='link')
- depends_on('pkgconfig', type='build')
- depends_on('openssl', type='link')
- depends_on('libiconv', type='link')
+ depends_on("libuv", type="link")
+ depends_on("pkgconfig", type="build")
+ depends_on("openssl", type="link")
+ depends_on("libiconv", type="link")
def configure_args(self):
- args = ["--without-python", "--disable-linux-caps",
- '--with-openssl={0}'.format(self.spec['openssl'].prefix)]
+ args = [
+ "--without-python",
+ "--disable-linux-caps",
+ "--with-openssl={0}".format(self.spec["openssl"].prefix),
+ ]
return args