summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/boost
diff options
context:
space:
mode:
authorMikael Simberg <simberg@cscs.ch>2021-08-30 13:19:54 +0200
committerGitHub <noreply@github.com>2021-08-30 05:19:54 -0600
commit44c0089be4f43d42564d2caf203dd510d7492d84 (patch)
tree1be9ecd139632700409e8522157a01ae00af2fd8 /var/spack/repos/builtin/packages/boost
parent65584a3b9279fd1f9a40b3bcdae47b491bd5beab (diff)
downloadspack-44c0089be4f43d42564d2caf203dd510d7492d84.tar.gz
spack-44c0089be4f43d42564d2caf203dd510d7492d84.tar.bz2
spack-44c0089be4f43d42564d2caf203dd510d7492d84.tar.xz
spack-44c0089be4f43d42564d2caf203dd510d7492d84.zip
Add patch to fix Boost with CCE and CUDA (#25534)
Diffstat (limited to 'var/spack/repos/builtin/packages/boost')
-rw-r--r--var/spack/repos/builtin/packages/boost/package.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/boost/package.py b/var/spack/repos/builtin/packages/boost/package.py
index 87e50c6379..1bf06b4f28 100644
--- a/var/spack/repos/builtin/packages/boost/package.py
+++ b/var/spack/repos/builtin/packages/boost/package.py
@@ -291,6 +291,13 @@ class Boost(Package):
# and https://github.com/boostorg/context/issues/177
patch("context-macho-gcc.patch", when="@1.65:1.76 +context platform=darwin %gcc")
+ # Fix float128 support when building with CUDA and Cray compiler
+ # See https://github.com/boostorg/config/pull/378
+ patch("https://github.com/boostorg/config/commit/fee1ad07968386b6d547f089311b7a2c1bf7fa55.patch",
+ sha256="3b159d65a0d3d2df2a21c6bf56ffaba943fce92d2d41d628b2c4d2e924e0f421",
+ when="@:1.76%cce",
+ level=2)
+
def patch(self):
# Disable SSSE3 and AVX2 when using the NVIDIA compiler
if self.spec.satisfies('%nvhpc'):