summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/botan/package.py
diff options
context:
space:
mode:
authorMassimiliano Culpo <massimiliano.culpo@gmail.com>2022-04-11 11:39:50 +0200
committerGitHub <noreply@github.com>2022-04-11 11:39:50 +0200
commitd0ad644ea6a0a3874fa7ed3785a4580b68b40b31 (patch)
tree5ef9c20ae73491cfc1ffd869fa7484094148ac43 /var/spack/repos/builtin/packages/botan/package.py
parentc2f470f4a6630116800ac78d8fd8d812b742cfec (diff)
downloadspack-d0ad644ea6a0a3874fa7ed3785a4580b68b40b31.tar.gz
spack-d0ad644ea6a0a3874fa7ed3785a4580b68b40b31.tar.bz2
spack-d0ad644ea6a0a3874fa7ed3785a4580b68b40b31.tar.xz
spack-d0ad644ea6a0a3874fa7ed3785a4580b68b40b31.zip
Remove custom phases in packages (1/n) (#29968)
* abi-dumper: remove custom phases * apktool: remove custom phases, add v2.6.1 * aragorn: remove custom phases * ascent: remove custom phases * astral: remove custom phases, add v5.7.1 * bigdft: remove redundant phase definitions * bazel: remove custom phases phase definitions * blasr: remove custom phases phase definitions * bmake: remove custom phases phase definitions, add v20220330 * botan: remove custom phases phase definitions * breakdancer: remove custom phases phase definitions * dnstracer: remove custom phases phase definitions * conduit: remove custom phases phase definitions * eclipse-gcj-parser: remove custom phases phase definitions * eem: remove custom phases phase definitions * fasttree: remove custom phases phase definitions * fleur: remove custom phases phase definitions * fpm: remove custom phases phase definitions * genie: remove custom phases phase definitions * gluegen: remove custom phases phase definitions * gnat: remove custom phases phase definitions * hpgmg: remove custom phases phase definitions * karma: remove custom phases phase definitions * libc: remove custom phases phase definitions
Diffstat (limited to 'var/spack/repos/builtin/packages/botan/package.py')
-rw-r--r--var/spack/repos/builtin/packages/botan/package.py15
1 files changed, 3 insertions, 12 deletions
diff --git a/var/spack/repos/builtin/packages/botan/package.py b/var/spack/repos/builtin/packages/botan/package.py
index b82c7c00e9..f067e31350 100644
--- a/var/spack/repos/builtin/packages/botan/package.py
+++ b/var/spack/repos/builtin/packages/botan/package.py
@@ -6,7 +6,7 @@
from spack import *
-class Botan(Package):
+class Botan(MakefilePackage):
"""Crypto and TLS for Modern C++"""
homepage = "https://botan.randombit.net/"
@@ -36,24 +36,15 @@ class Botan(Package):
depends_on('python', type='build')
depends_on('py-sphinx@1.2:', type='build', when='+doc')
- phases = ['configure', 'build', 'install']
-
- def configure(self, spec, prefix):
+ def edit(self, spec, prefix):
configure = Executable('./configure.py')
configure(*self.configure_args())
def configure_args(self):
spec = self.spec
- args = []
- args.append('--prefix=' + prefix)
+ args = ['--prefix={0}'.format(self.prefix)]
if '+doc' in spec:
args.append('--with-documentation')
else:
args.append('--without-documentation')
return args
-
- def build(self, spec, prefix):
- make()
-
- def install(self, spec, prefix):
- make('install')