summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/catalyst/package.py
diff options
context:
space:
mode:
authorTamara Dahlgren <35777542+tldahlgren@users.noreply.github.com>2019-06-12 17:07:47 -0700
committerPeter Scheibel <scheibel1@llnl.gov>2019-06-12 17:07:47 -0700
commit16530f84be04b8466769b9b74fe920d67006b988 (patch)
tree176d21a328e0014ac77d7e14f0f653353581b1af /var/spack/repos/builtin/packages/catalyst/package.py
parent3ce90741a3dd82b22139f82a555e0158c796c169 (diff)
downloadspack-16530f84be04b8466769b9b74fe920d67006b988.tar.gz
spack-16530f84be04b8466769b9b74fe920d67006b988.tar.bz2
spack-16530f84be04b8466769b9b74fe920d67006b988.tar.xz
spack-16530f84be04b8466769b9b74fe920d67006b988.zip
Update remaining packages to use Stage.source_path (#11662)
#11528 updated Stage to always store a Package's source in a fixed directory accessible via `Stage.source_path` This left behind a number of packages which were expecting to access the source code via `Stage.path`. This Updates those packages to use `Stage.source_path` instead. This also updates the name of the fixed directory: The original name of the fixed directory was "src", so if an expanded archive created a "src" directory, then users inspecting the directory structure could see paths like "src/src" (which wasn't wrong but could be confusing). Therefore this also updates the name of the fixed directory to "spack-src".
Diffstat (limited to 'var/spack/repos/builtin/packages/catalyst/package.py')
-rw-r--r--var/spack/repos/builtin/packages/catalyst/package.py9
1 files changed, 5 insertions, 4 deletions
diff --git a/var/spack/repos/builtin/packages/catalyst/package.py b/var/spack/repos/builtin/packages/catalyst/package.py
index e64c97a749..03f4609b60 100644
--- a/var/spack/repos/builtin/packages/catalyst/package.py
+++ b/var/spack/repos/builtin/packages/catalyst/package.py
@@ -119,7 +119,7 @@ class Catalyst(CMakePackage):
super(Catalyst, self).do_stage(mirror_only)
# extract the catalyst part
- paraview_dir = os.path.join(self.stage.path,
+ paraview_dir = os.path.join(self.stage.source_path,
'ParaView-v' + str(self.version))
catalyst_script = os.path.join(paraview_dir, 'Catalyst', 'catalyze.py')
editions_dir = os.path.join(paraview_dir, 'Catalyst', 'Editions')
@@ -135,10 +135,10 @@ class Catalyst(CMakePackage):
if not os.path.isdir(catalyst_source_dir):
os.mkdir(catalyst_source_dir)
subprocess.check_call(command)
- tty.msg("Generated catalyst source in %s" % self.stage.path)
+ tty.msg("Generated catalyst source in %s" % self.stage.source_path)
else:
tty.msg("Already generated %s in %s" % (self.name,
- self.stage.path))
+ self.stage.source_path))
def setup_environment(self, spack_env, run_env):
# paraview 5.5 and later
@@ -174,7 +174,8 @@ class Catalyst(CMakePackage):
:return: directory containing CMakeLists.txt
"""
- return os.path.join(self.stage.path, 'Catalyst-v' + str(self.version))
+ return os.path.join(self.stage.source_path,
+ 'Catalyst-v' + str(self.version))
@property
def build_directory(self):