summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/cgal/package.py
diff options
context:
space:
mode:
authorTamara Dahlgren <35777542+tldahlgren@users.noreply.github.com>2021-09-13 09:21:35 -0700
committerGitHub <noreply@github.com>2021-09-13 09:21:35 -0700
commitbafd84e191d66b5812c1e197bf9d207479bc49e7 (patch)
tree55ed8f09bcc503a275a453a1368fb0498586e7f7 /var/spack/repos/builtin/packages/cgal/package.py
parent1e08f31e1650995b7fae8abf4c367e8c7cd34259 (diff)
downloadspack-bafd84e191d66b5812c1e197bf9d207479bc49e7.tar.gz
spack-bafd84e191d66b5812c1e197bf9d207479bc49e7.tar.bz2
spack-bafd84e191d66b5812c1e197bf9d207479bc49e7.tar.xz
spack-bafd84e191d66b5812c1e197bf9d207479bc49e7.zip
Switch http to https where latter exists (#25672)
* Switch http to https where latter exists * Hopefully restore original permissions * Add URL updates after include the -L curl option * Manual corrections to select URL format strings
Diffstat (limited to 'var/spack/repos/builtin/packages/cgal/package.py')
-rw-r--r--var/spack/repos/builtin/packages/cgal/package.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/var/spack/repos/builtin/packages/cgal/package.py b/var/spack/repos/builtin/packages/cgal/package.py
index 4d579221b0..24cc1d1b4e 100644
--- a/var/spack/repos/builtin/packages/cgal/package.py
+++ b/var/spack/repos/builtin/packages/cgal/package.py
@@ -35,11 +35,11 @@ class Cgal(CMakePackage):
description='Install in header only mode')
# ---- See "7 CGAL Libraries" at:
- # http://doc.cgal.org/latest/Manual/installation.html
+ # https://doc.cgal.org/latest/Manual/installation.html
# The CORE library provides exact arithmetic for geometric computations.
- # See: http://cs.nyu.edu/exact/core_pages/
- # http://cs.nyu.edu/exact/core_pages/svn-core.html
+ # See: https://cs.nyu.edu/exact/core_pages/
+ # https://cs.nyu.edu/exact/core_pages/svn-core.html
variant('core', default=False,
description='Build the CORE library for algebraic numbers')
variant('imageio', default=False,
@@ -91,7 +91,7 @@ class Cgal(CMakePackage):
def cmake_args(self):
# Installation instructions:
- # http://doc.cgal.org/latest/Manual/installation.html
+ # https://doc.cgal.org/latest/Manual/installation.html
spec = self.spec
variant_bool = lambda feature: str(feature in spec)
cmake_args = []