summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/cray-fftw/package.py
diff options
context:
space:
mode:
authorHarmen Stoppels <harmenstoppels@gmail.com>2021-01-05 19:22:49 +0100
committerGitHub <noreply@github.com>2021-01-05 10:22:49 -0800
commit4a7c4e66674e6639974dc55c856337ea7ed81a1d (patch)
tree7d9b73536ad281190745abde133ce1d32da6300d /var/spack/repos/builtin/packages/cray-fftw/package.py
parenta1e4465c596d150bd6b831b5206aa1e6d92f4e8f (diff)
downloadspack-4a7c4e66674e6639974dc55c856337ea7ed81a1d.tar.gz
spack-4a7c4e66674e6639974dc55c856337ea7ed81a1d.tar.bz2
spack-4a7c4e66674e6639974dc55c856337ea7ed81a1d.tar.xz
spack-4a7c4e66674e6639974dc55c856337ea7ed81a1d.zip
Add cray-fftw (#20654)
Diffstat (limited to 'var/spack/repos/builtin/packages/cray-fftw/package.py')
-rw-r--r--var/spack/repos/builtin/packages/cray-fftw/package.py34
1 files changed, 34 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/cray-fftw/package.py b/var/spack/repos/builtin/packages/cray-fftw/package.py
new file mode 100644
index 0000000000..a2f913f827
--- /dev/null
+++ b/var/spack/repos/builtin/packages/cray-fftw/package.py
@@ -0,0 +1,34 @@
+# Copyright 2013-2021 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
+#
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
+from spack import *
+
+
+class CrayFftw(Package):
+ """FFTW is a C subroutine library for computing the discrete Fourier
+ transform (DFT) in one or more dimensions, of arbitrary input
+ size, and of both real and complex data (as well as of even/odd
+ data, i.e. the discrete cosine/sine transforms or DCT/DST).
+ This package is a wrapper for Cray's version of FFTW.
+
+ To install this package, list it as an external package in packages.yaml,
+ and make sure to load the correct cray-fftw module. In some cases you
+ need to load cray-mpich before cray-fftw.
+ """
+
+ homepage = "https://docs.nersc.gov/development/libraries/fftw/"
+ has_code = False # Skip attempts to fetch source that is not available
+
+ maintainers = ['haampie']
+
+ version('3.3.8.8')
+ version('3.3.8.7')
+
+ provides('fftw-api@3')
+
+ def install(self, spec, prefix):
+ raise InstallError(
+ self.spec.format('{name} is not installable, you need to specify '
+ 'it as an external package in packages.yaml'))