summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/cray-fftw/package.py
diff options
context:
space:
mode:
authorTodd Gamblin <tgamblin@llnl.gov>2022-07-30 15:19:18 -0700
committerTodd Gamblin <tgamblin@llnl.gov>2022-07-31 13:29:20 -0700
commitf52f6e99dbf1131886a80112b8c79dfc414afb7c (patch)
tree05cb7d64b2395922f2f24683da49f472075be12c /var/spack/repos/builtin/packages/cray-fftw/package.py
parent549ba1ed32372c67fc57271cde3797d58b7dec6e (diff)
downloadspack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.gz
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.bz2
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.xz
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.zip
black: reformat entire repository with black
Diffstat (limited to 'var/spack/repos/builtin/packages/cray-fftw/package.py')
-rw-r--r--var/spack/repos/builtin/packages/cray-fftw/package.py70
1 files changed, 36 insertions, 34 deletions
diff --git a/var/spack/repos/builtin/packages/cray-fftw/package.py b/var/spack/repos/builtin/packages/cray-fftw/package.py
index 376f154406..a9cdaa9445 100644
--- a/var/spack/repos/builtin/packages/cray-fftw/package.py
+++ b/var/spack/repos/builtin/packages/cray-fftw/package.py
@@ -8,69 +8,71 @@ from spack.package import *
class CrayFftw(Package):
"""FFTW is a C subroutine library for computing the discrete Fourier
- transform (DFT) in one or more dimensions, of arbitrary input
- size, and of both real and complex data (as well as of even/odd
- data, i.e. the discrete cosine/sine transforms or DCT/DST).
- This package is a wrapper for Cray's version of FFTW.
+ transform (DFT) in one or more dimensions, of arbitrary input
+ size, and of both real and complex data (as well as of even/odd
+ data, i.e. the discrete cosine/sine transforms or DCT/DST).
+ This package is a wrapper for Cray's version of FFTW.
- To install this package, list it as an external package in packages.yaml,
- and make sure to load the correct cray-fftw module. In some cases you
- need to load cray-mpich before cray-fftw.
- """
+ To install this package, list it as an external package in packages.yaml,
+ and make sure to load the correct cray-fftw module. In some cases you
+ need to load cray-mpich before cray-fftw.
+ """
homepage = "https://support.hpe.com/"
- has_code = False # Skip attempts to fetch source that is not available
+ has_code = False # Skip attempts to fetch source that is not available
- maintainers = ['haampie', 'lukebroskop']
+ maintainers = ["haampie", "lukebroskop"]
- version('3.3.8.12')
- version('3.3.8.8')
- version('3.3.8.7')
+ version("3.3.8.12")
+ version("3.3.8.8")
+ version("3.3.8.7")
- provides('fftw-api@3')
+ provides("fftw-api@3")
variant(
- 'precision', values=any_combination_of(
- 'float', 'double'
- ).prohibit_empty_set().with_default('float,double'),
- description='Build the selected floating-point precision libraries'
+ "precision",
+ values=any_combination_of("float", "double")
+ .prohibit_empty_set()
+ .with_default("float,double"),
+ description="Build the selected floating-point precision libraries",
)
- variant('openmp', default=False, description="Enable OpenMP support.")
- variant('mpi', default=True, description='Activate MPI support')
- depends_on('mpi', when='+mpi')
+ variant("openmp", default=False, description="Enable OpenMP support.")
+ variant("mpi", default=True, description="Activate MPI support")
+ depends_on("mpi", when="+mpi")
def install(self, spec, prefix):
raise InstallError(
- self.spec.format('{name} is not installable, you need to specify '
- 'it as an external package in packages.yaml'))
+ self.spec.format(
+ "{name} is not installable, you need to specify "
+ "it as an external package in packages.yaml"
+ )
+ )
@property
def libs(self):
# Reduce repetitions of entries
- query_parameters = list(llnl.util.lang.dedupe(
- self.spec.last_query.extra_parameters
- ))
+ query_parameters = list(llnl.util.lang.dedupe(self.spec.last_query.extra_parameters))
# List of all the suffixes associated with float precisions
precisions = [
- ('float', 'f'),
- ('double', ''),
+ ("float", "f"),
+ ("double", ""),
]
# Retrieve the correct suffixes, or use double as a default
- suffixes = [v for k, v in precisions if k in query_parameters] or ['']
+ suffixes = [v for k, v in precisions if k in query_parameters] or [""]
# Construct the list of libraries that needs to be found
libraries = []
for sfx in suffixes:
- if 'mpi' in query_parameters and '+mpi' in self.spec:
- libraries.append('libfftw3' + sfx + '_mpi')
+ if "mpi" in query_parameters and "+mpi" in self.spec:
+ libraries.append("libfftw3" + sfx + "_mpi")
- if 'openmp' in query_parameters and '+openmp' in self.spec:
- libraries.append('libfftw3' + sfx + '_omp')
+ if "openmp" in query_parameters and "+openmp" in self.spec:
+ libraries.append("libfftw3" + sfx + "_omp")
- libraries.append('libfftw3' + sfx)
+ libraries.append("libfftw3" + sfx)
return find_libraries(libraries, root=self.prefix, recursive=True)