summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/curl/package.py
diff options
context:
space:
mode:
authorHarmen Stoppels <harmenstoppels@gmail.com>2021-09-29 18:05:58 +0200
committerGitHub <noreply@github.com>2021-09-29 09:05:58 -0700
commit7fdb879308247c060654a95a9eedfbc628533f01 (patch)
treede26ab1ae7acb292c3344563f2b92f6654a9b501 /var/spack/repos/builtin/packages/curl/package.py
parent24263c9e9229be85c1a5047a412c16191de7fa73 (diff)
downloadspack-7fdb879308247c060654a95a9eedfbc628533f01.tar.gz
spack-7fdb879308247c060654a95a9eedfbc628533f01.tar.bz2
spack-7fdb879308247c060654a95a9eedfbc628533f01.tar.xz
spack-7fdb879308247c060654a95a9eedfbc628533f01.zip
ca-certificates-mozilla for openssl & curl (#26263)
1. Changes the variant of openssl to `certs=mozilla/system/none` so that users can pick whether they want Spack or system certs, or if they don't want certs at all. 2. Keeps the default behavior of openssl to use certs=systems. 3. Changes the curl configuration to not guess the ca path during config, but rather fall back to whatever the tls provider is configured with. If we don't do this, curl will still pick up system certs if it finds them. As a minor fix, it also adds the build dep `pkgconfig` to curl, since that's being used during the configure phase to get openssl compilation flags.
Diffstat (limited to 'var/spack/repos/builtin/packages/curl/package.py')
-rw-r--r--var/spack/repos/builtin/packages/curl/package.py6
1 files changed, 6 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/curl/package.py b/var/spack/repos/builtin/packages/curl/package.py
index 1db1b0de3e..7b04455e28 100644
--- a/var/spack/repos/builtin/packages/curl/package.py
+++ b/var/spack/repos/builtin/packages/curl/package.py
@@ -97,6 +97,9 @@ class Curl(AutotoolsPackage):
depends_on('libssh', when='+libssh')
depends_on('krb5', when='+gssapi')
+ # curl queries pkgconfig for openssl compilation flags
+ depends_on('pkgconfig', type='build')
+
def configure_args(self):
spec = self.spec
@@ -108,6 +111,9 @@ class Curl(AutotoolsPackage):
'--without-libgsasl',
'--without-libpsl',
'--without-zstd',
+ '--without-ca-bundle',
+ '--without-ca-path',
+ '--with-ca-fallback',
]
# https://daniel.haxx.se/blog/2021/06/07/bye-bye-metalink-in-curl/