summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/gromacs
diff options
context:
space:
mode:
authorMark Abraham <Mark.J.Abraham@gmail.com>2021-09-10 00:38:31 +0200
committerGitHub <noreply@github.com>2021-09-09 16:38:31 -0600
commit9084ad69b453e14b47e60210e60d76f58e001721 (patch)
treef15a4739ccbbb1fb5d6595078a01c5d96296b1ca /var/spack/repos/builtin/packages/gromacs
parent59d8031076b438007d1a9293d51f5b7e32e07820 (diff)
downloadspack-9084ad69b453e14b47e60210e60d76f58e001721.tar.gz
spack-9084ad69b453e14b47e60210e60d76f58e001721.tar.bz2
spack-9084ad69b453e14b47e60210e60d76f58e001721.tar.xz
spack-9084ad69b453e14b47e60210e60d76f58e001721.zip
Have GROMACS log files indicate spack was used (#25869)
Knowing that spack has patched the code and organized the build is potentially valuable information for GROMACS users and developers troubleshooting their builds. PLUMED does further patches to GROMACS, so that is expressed directly also.
Diffstat (limited to 'var/spack/repos/builtin/packages/gromacs')
-rw-r--r--var/spack/repos/builtin/packages/gromacs/package.py6
1 files changed, 6 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/gromacs/package.py b/var/spack/repos/builtin/packages/gromacs/package.py
index 102d484122..221be3a4f4 100644
--- a/var/spack/repos/builtin/packages/gromacs/package.py
+++ b/var/spack/repos/builtin/packages/gromacs/package.py
@@ -390,4 +390,10 @@ class Gromacs(CMakePackage):
options.append('-DFFTWF_LIBRARIES={0}'.
format(self.spec['amdfftw'].libs.joined(';')))
+ # Ensure that the GROMACS log files report how the code was patched
+ # during the build, so that any problems are easier to diagnose.
+ if '+plumed' in self.spec:
+ options.append('-DGMX_VERSION_STRING_OF_FORK=PLUMED-spack')
+ else:
+ options.append('-DGMX_VERSION_STRING_OF_FORK=spack')
return options