summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/intel-oneapi-mkl/package.py
diff options
context:
space:
mode:
authorTiziano Müller <tm@dev-zero.ch>2023-03-01 21:01:00 +0100
committerGitHub <noreply@github.com>2023-03-01 12:01:00 -0800
commit44705b0a6e76799a5b67943b5310e553d7de2ea7 (patch)
tree8863ca7748777b2e0bafff59b03092bae5b2c77a /var/spack/repos/builtin/packages/intel-oneapi-mkl/package.py
parent3bb03ea7d18bc1067c02ce41295afa78b79b7524 (diff)
downloadspack-44705b0a6e76799a5b67943b5310e553d7de2ea7.tar.gz
spack-44705b0a6e76799a5b67943b5310e553d7de2ea7.tar.bz2
spack-44705b0a6e76799a5b67943b5310e553d7de2ea7.tar.xz
spack-44705b0a6e76799a5b67943b5310e553d7de2ea7.zip
cp2k: fix builds on macOS, workaround reported issue with __contains__ (#35584)
Co-authored-by: Robert Cohn <rscohn2@gmail.com> Co-authored-by: Massimiliano Culpo <massimiliano.culpo@gmail.com>
Diffstat (limited to 'var/spack/repos/builtin/packages/intel-oneapi-mkl/package.py')
-rw-r--r--var/spack/repos/builtin/packages/intel-oneapi-mkl/package.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/var/spack/repos/builtin/packages/intel-oneapi-mkl/package.py b/var/spack/repos/builtin/packages/intel-oneapi-mkl/package.py
index 8be451f656..6573ea7211 100644
--- a/var/spack/repos/builtin/packages/intel-oneapi-mkl/package.py
+++ b/var/spack/repos/builtin/packages/intel-oneapi-mkl/package.py
@@ -3,6 +3,7 @@
#
# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+from os.path import dirname, isdir
from spack.package import *
@@ -153,7 +154,10 @@ class IntelOneapiMkl(IntelOneApiLibraryPackage):
if "+cluster" in self.spec:
libs.append(self._xlp64_lib("libmkl_blacs_intelmpi"))
- return find_libraries(libs, self.component_prefix.lib.intel64, shared=shared)
+ lib_path = self.component_prefix.lib.intel64
+ lib_path = lib_path if isdir(lib_path) else dirname(lib_path)
+
+ return find_libraries(libs, lib_path, shared=shared)
def _xlp64_lib(self, lib):
return lib + ("_ilp64" if "+ilp64" in self.spec else "_lp64")