summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/llvm/package.py
diff options
context:
space:
mode:
authorMartin Aumüller <aumuell@reserv.at>2023-07-11 18:44:18 +0200
committerGitHub <noreply@github.com>2023-07-11 09:44:18 -0700
commit2e695fa03fd9a5dd0614d678f8c78361b0a06f19 (patch)
treed97872e3fbf3d7d99fe8b2cd625a38c8bc8e17f4 /var/spack/repos/builtin/packages/llvm/package.py
parent5fc949f252104336d3664966f02832c21bc857e7 (diff)
downloadspack-2e695fa03fd9a5dd0614d678f8c78361b0a06f19.tar.gz
spack-2e695fa03fd9a5dd0614d678f8c78361b0a06f19.tar.bz2
spack-2e695fa03fd9a5dd0614d678f8c78361b0a06f19.tar.xz
spack-2e695fa03fd9a5dd0614d678f8c78361b0a06f19.zip
ispc: on ARM, build with ARM targets enabled, and updates (#38080)
* llvm: fix build with libcxx=none * ispc: checksum 1.20.0 * ispc: ensure that it does not crash immediately this would happen if linked to the wrong libc++ * ispc: fix build on macos find ncurses instead of curses and link against tinfo in order to avoid unresolved references to _del_curterm, _set_curterm, _setupterm, and _tigetnum * ispc: enable arm targets, if building on arm * ispc: remove double cmake argument I forgot to remove the constant -DARM_ENABLED=FALSE when adding -DARM_ENABLED with a value depending on target architecture * ispc: fix linux build since 1.20, linux build uses TBB as default tasking system and thus needs to depend on it * ispc: try to fix link error on linux link against both curses (as before) and tinfo (added because of macos) * ispc: update for recent llvm changes libcxx=none instead of ~libcxx
Diffstat (limited to 'var/spack/repos/builtin/packages/llvm/package.py')
-rw-r--r--var/spack/repos/builtin/packages/llvm/package.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/llvm/package.py b/var/spack/repos/builtin/packages/llvm/package.py
index 9b537df57a..120ce06808 100644
--- a/var/spack/repos/builtin/packages/llvm/package.py
+++ b/var/spack/repos/builtin/packages/llvm/package.py
@@ -885,6 +885,10 @@ class Llvm(CMakePackage, CudaPackage):
if self.spec.satisfies("~code_signing platform=darwin"):
cmake_args.append(define("LLDB_USE_SYSTEM_DEBUGSERVER", True))
+ # LLDB test suite requires libc++
+ if "libcxx=none" in spec:
+ cmake_args.append(define("LLDB_INCLUDE_TESTS", False))
+
# Enable building with CLT [and not require full Xcode]
# https://github.com/llvm/llvm-project/issues/57037
if self.spec.satisfies("@15.0.0: platform=darwin"):