summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/llvm/package.py
diff options
context:
space:
mode:
authorHarmen Stoppels <me@harmenstoppels.nl>2023-10-18 19:04:49 +0200
committerGitHub <noreply@github.com>2023-10-18 19:04:49 +0200
commit55198c49e5ca73f140d1fa348893f3e8b8217b0f (patch)
tree1a4bc140417ca00a06d1262c86e628e51d97eb2b /var/spack/repos/builtin/packages/llvm/package.py
parentdc071a3995fa32006dd4abdd3a47248c748ff454 (diff)
downloadspack-55198c49e5ca73f140d1fa348893f3e8b8217b0f.tar.gz
spack-55198c49e5ca73f140d1fa348893f3e8b8217b0f.tar.bz2
spack-55198c49e5ca73f140d1fa348893f3e8b8217b0f.tar.xz
spack-55198c49e5ca73f140d1fa348893f3e8b8217b0f.zip
llvm: fix ncurses+termlib linking in lldb (#40594)
Diffstat (limited to 'var/spack/repos/builtin/packages/llvm/package.py')
-rw-r--r--var/spack/repos/builtin/packages/llvm/package.py10
1 files changed, 10 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/llvm/package.py b/var/spack/repos/builtin/packages/llvm/package.py
index df0e762fc5..b7a78c6fdd 100644
--- a/var/spack/repos/builtin/packages/llvm/package.py
+++ b/var/spack/repos/builtin/packages/llvm/package.py
@@ -562,6 +562,16 @@ class Llvm(CMakePackage, CudaPackage):
patch("add-include-for-libelf-llvm-12-14.patch", when="@12:14")
patch("add-include-for-libelf-llvm-15.patch", when="@15")
+ @when("@14:17")
+ def patch(self):
+ # https://github.com/llvm/llvm-project/pull/69458
+ filter_file(
+ r"${TERMINFO_LIB}",
+ r"${Terminfo_LIBRARIES}",
+ "lldb/source/Core/CMakeLists.txt",
+ string=True,
+ )
+
# The functions and attributes below implement external package
# detection for LLVM. See:
#