summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-hypothesis/package.py
diff options
context:
space:
mode:
authorAdam J. Stewart <ajstewart426@gmail.com>2024-04-10 17:56:21 +0200
committerGitHub <noreply@github.com>2024-04-10 17:56:21 +0200
commit4c0cdb99b3c1f4837f386c0d70e88c6dd3b5c889 (patch)
treec35a09947b89c11f94a02c641ea596b5c11db197 /var/spack/repos/builtin/packages/py-hypothesis/package.py
parentf22d009c6dfa49a30aad23266749a34cd57f994c (diff)
downloadspack-4c0cdb99b3c1f4837f386c0d70e88c6dd3b5c889.tar.gz
spack-4c0cdb99b3c1f4837f386c0d70e88c6dd3b5c889.tar.bz2
spack-4c0cdb99b3c1f4837f386c0d70e88c6dd3b5c889.tar.xz
spack-4c0cdb99b3c1f4837f386c0d70e88c6dd3b5c889.zip
py-scipy: add v1.12 and v1.13 (#42213)
Diffstat (limited to 'var/spack/repos/builtin/packages/py-hypothesis/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-hypothesis/package.py52
1 files changed, 21 insertions, 31 deletions
diff --git a/var/spack/repos/builtin/packages/py-hypothesis/package.py b/var/spack/repos/builtin/packages/py-hypothesis/package.py
index 90469c997b..e06e14ff84 100644
--- a/var/spack/repos/builtin/packages/py-hypothesis/package.py
+++ b/var/spack/repos/builtin/packages/py-hypothesis/package.py
@@ -14,6 +14,7 @@ class PyHypothesis(PythonPackage):
license("MPL-2.0")
+ version("6.96.2", sha256="524a0ac22c8dfff640f21f496b85ee193a470e8570ab7707b8e3bfccd7da34a6")
version("6.23.1", sha256="23a1b0488aec5719e2f9e399342e10f30d497cbb9fd39470ef0975c1b502ae35")
version("5.3.0", sha256="c9fdb53fe3bf1f8e7dcca1a7dd6e430862502f088aca2903d141511212e79429")
version("4.57.1", sha256="3c4369a4b0a1348561048bcda5f1db951a1b8e2a514ea8e8c70d36e656bf6fa0")
@@ -22,42 +23,31 @@ class PyHypothesis(PythonPackage):
version("4.7.2", sha256="87944c6379f77634474b88abbf1e5ed5fe966637cc926131eda5e2af5b54a608")
version("3.7.0", sha256="0fea49d08f2d5884f014151a5af6fb48d862f6ad567ffc4a2e84abf2f186c423")
- depends_on("python@2.7:2.8,3.5:", type=("build", "run"))
- depends_on("python@3.6:", type=("build", "run"), when="@6:")
- depends_on("py-setuptools@36.2:", type=("build"))
- depends_on("py-attrs@19.2.0:", when="@4.38.2:", type=("build", "run"))
- depends_on("py-attrs@16.0.0:", when="@3.44.22:", type=("build", "run"))
+ variant("django", default=False, description="Enable django support")
+ variant("numpy", default=False, description="Enable numpy support")
+ variant("pandas", default=False, description="Enable pandas support")
+
+ depends_on("py-setuptools@36.2:", type="build")
+ depends_on("py-attrs@22.2:", when="@6.96:", type=("build", "run"))
+ depends_on("py-attrs@19.2:", when="@4.38.2:", type=("build", "run"))
+ depends_on("py-attrs@16.0:", when="@3.44.22:", type=("build", "run"))
depends_on("py-attrs", when="@3.28.0:", type=("build", "run"))
- depends_on("py-sortedcontainers@2.1.0:2", type=("build", "run"), when="@4.57.1:")
+ depends_on("py-exceptiongroup@1:", when="@6.96: ^python@:3.10", type=("build", "run"))
+ depends_on("py-sortedcontainers@2.1:2", type=("build", "run"), when="@4.57.1:")
+ depends_on("py-django@3.2:", type="run", when="@6.96: +django")
depends_on("py-django@2.2:", type="run", when="+django")
depends_on("py-pytz@2014.1:", type="run", when="+django")
+ depends_on("py-numpy@1.17.3:", type="run", when="@6.96: +numpy")
depends_on("py-numpy@1.9.0:", type="run", when="+numpy")
+ depends_on("py-pandas@1.1:", type="run", when="@6.96: +pandas")
depends_on("py-pandas@0.25:", type="run", when="+pandas")
- variant("django", default=False, description="Enable django support")
- variant("numpy", default=False, description="Enable numpy support")
- variant("pandas", default=False, description="Enable pandas support")
-
- # All modules except for 'hypothesis.extra.pandas' and 'hypothesis.extra.django',
- # which are optional and are only added when their variants are enabled:
- import_test_modules = [
- "hypothesis",
- "hypothesis.extra",
- "hypothesis.utils",
- "hypothesis.strategies",
- "hypothesis.strategies._internal",
- "hypothesis.vendor",
- "hypothesis.internal",
- "hypothesis.internal.conjecture",
- "hypothesis.internal.conjecture.shrinking",
- "hypothesis.internal.conjecture.dfa",
- ]
-
@property
- def import_modules(self):
- if self.spec.satisfies("+pandas"):
- self.import_test_modules.append("hypothesis.extra.pandas")
- if self.spec.satisfies("+django"):
- self.import_test_modules.append("hypothesis.extra.django")
- return self.import_test_modules
+ def skip_modules(self):
+ modules = []
+ if "+django" not in self.spec:
+ modules.append("hypothesis.extra.django")
+ if "+pandas" not in self.spec:
+ modules.append("hypothesis.extra.pandas")
+ return modules