summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-pyproject-parser/package.py
diff options
context:
space:
mode:
authorFábio de Andrade Barboza <69045579+Barbozafab@users.noreply.github.com>2023-09-11 17:12:46 -0300
committerGitHub <noreply@github.com>2023-09-11 15:12:46 -0500
commit873652a33ec24e8e9468cab4038c28072cf0000a (patch)
treecc336d17e4cbef97074bfcfca808058b71a0a2d0 /var/spack/repos/builtin/packages/py-pyproject-parser/package.py
parent3f686734aba9b8e1562d0f1897c50f64c9c886cf (diff)
downloadspack-873652a33ec24e8e9468cab4038c28072cf0000a.tar.gz
spack-873652a33ec24e8e9468cab4038c28072cf0000a.tar.bz2
spack-873652a33ec24e8e9468cab4038c28072cf0000a.tar.xz
spack-873652a33ec24e8e9468cab4038c28072cf0000a.zip
py-enum-tools: add new package and dependencies (#39672)
* Adds package 'enum-tools' * Fixes syntax * py-enum-tools: update pypi link and dependencies * py-whey: add new package * py-consolekit: add new package * py-shippinglabel: add new package * py-project-parser: add new package * py-handy-archives: add new package * py-domdf-python-tools: add new package * py-dom-toml: add new package * py-dist-meta: add new package * py-deprecation-alias: add new package * py-pygments: add versions 2.16.0 and 2.16.1 * py-mistletoe: add new package * py-apeye: add new package * py-apeye-core: add new package * Fix dependencies' names and remove redundancies * Fix style * py-enum-tools: fix dependencies * py-mistletoe: update dependencies * Apply suggestions from code review Co-authored-by: Adam J. Stewart <ajstewart426@gmail.com> * py-whey: fix dependencies * py-whey: fix style * py-apeye: fix dependencies --------- Co-authored-by: Fábio de Andrade Barboza <f168817@dac.unicamp.br> Co-authored-by: Adam J. Stewart <ajstewart426@gmail.com>
Diffstat (limited to 'var/spack/repos/builtin/packages/py-pyproject-parser/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-pyproject-parser/package.py31
1 files changed, 31 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/py-pyproject-parser/package.py b/var/spack/repos/builtin/packages/py-pyproject-parser/package.py
new file mode 100644
index 0000000000..63a164ce50
--- /dev/null
+++ b/var/spack/repos/builtin/packages/py-pyproject-parser/package.py
@@ -0,0 +1,31 @@
+# Copyright 2013-2023 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
+#
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
+
+from spack.package import *
+
+
+class PyPyprojectParser(PythonPackage):
+ """Parser for 'pyproject.toml'"""
+
+ homepage = "https://github.com/repo-helper/pyproject-parser"
+ pypi = "pyproject_parser/pyproject-parser-0.9.1.tar.gz"
+
+ version("0.9.1", sha256="fa0b2ff78bc95788b08d00e1aafa66d3f7f3ab693f19d9c2e23e20000a69fd9b")
+
+ depends_on("py-wheel@0.34.2:", type="build")
+ depends_on("py-setuptools@40.6:", type="build")
+ conflicts("^py-setuptools@61")
+ depends_on("py-apeye-core@1:", type=("build", "run"))
+ depends_on("py-attrs@20.3:", type=("build", "run"))
+ depends_on("py-dom-toml@0.4:", type=("build", "run"))
+ depends_on("py-domdf-python-tools@2.8:", type=("build", "run"))
+ depends_on("py-natsort@7.1.1:", type=("build", "run"))
+ depends_on("py-packaging@20.9:", type=("build", "run"))
+ depends_on("py-shippinglabel@1:", type=("build", "run"))
+ depends_on("py-toml@0.10.2:", type=("build", "run"))
+ depends_on("py-tomli@1.2.3:", type=("build", "run"), when="^python@:3.10")
+ depends_on("py-typing-extensions@3.7.4.3:", type=("build", "run"))
+ conflicts("^py-typing-extensions@4.7.0")