summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/r/package.py
diff options
context:
space:
mode:
authorElizabeth Fischer <rpf2116@columbia.edu>2017-01-07 22:59:02 -0500
committerTodd Gamblin <tgamblin@llnl.gov>2017-01-07 19:59:02 -0800
commit402dfe30f99f129d310ccde3381ea7ac8c5fca53 (patch)
tree6d82df90f623c68c99abe1a16457793d41cdeb66 /var/spack/repos/builtin/packages/r/package.py
parent68baac0549e816dce68ebab40c701b92f5f46dec (diff)
downloadspack-402dfe30f99f129d310ccde3381ea7ac8c5fca53.tar.gz
spack-402dfe30f99f129d310ccde3381ea7ac8c5fca53.tar.bz2
spack-402dfe30f99f129d310ccde3381ea7ac8c5fca53.tar.xz
spack-402dfe30f99f129d310ccde3381ea7ac8c5fca53.zip
Get Rid of nobuild, nolink, and alldeps (#2765)
* Removing the nobuild, nolink, and alldeps dependency types in favor of being explicit. * This will help with maintenance going forward, as adding more dependency types won't affect existing declared dependencies in weird ways. * default deptype is still `('build', 'link')`
Diffstat (limited to 'var/spack/repos/builtin/packages/r/package.py')
-rw-r--r--var/spack/repos/builtin/packages/r/package.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/var/spack/repos/builtin/packages/r/package.py b/var/spack/repos/builtin/packages/r/package.py
index a60fa8122c..df447eba3e 100644
--- a/var/spack/repos/builtin/packages/r/package.py
+++ b/var/spack/repos/builtin/packages/r/package.py
@@ -22,6 +22,7 @@
# License along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
##############################################################################
+
from spack import *
from spack.util.environment import *
import shutil
@@ -139,7 +140,8 @@ class R(Package):
# Set R_LIBS to include the library dir for the
# extension and any other R extensions it depends on.
r_libs_path = []
- for d in extension_spec.traverse(deptype=nolink, deptype_query='run'):
+ for d in extension_spec.traverse(
+ deptype=('build', 'run'), deptype_query='run'):
if d.package.extends(self.spec):
r_libs_path.append(join_path(d.prefix, self.r_lib_dir))