summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/rendercheck/package.py
diff options
context:
space:
mode:
authoralalazo <massimiliano.culpo@googlemail.com>2016-10-21 12:38:43 +0200
committeralalazo <massimiliano.culpo@googlemail.com>2016-10-21 12:38:43 +0200
commit213e3f0860ada9c1f7a5a945d95398c717bfb7aa (patch)
treeb2559492525283e4de531989d4e9ce82d56ad0c4 /var/spack/repos/builtin/packages/rendercheck/package.py
parentdd56784d2861d866cc3b6e15a145331297d283f0 (diff)
parent8de143a99440d708e8e22bd63bcad25c483d8ffa (diff)
downloadspack-213e3f0860ada9c1f7a5a945d95398c717bfb7aa.tar.gz
spack-213e3f0860ada9c1f7a5a945d95398c717bfb7aa.tar.bz2
spack-213e3f0860ada9c1f7a5a945d95398c717bfb7aa.tar.xz
spack-213e3f0860ada9c1f7a5a945d95398c717bfb7aa.zip
Merge branch 'develop' of https://github.com/LLNL/spack into features/install_with_phases_rebase
Conflicts: lib/spack/spack/cmd/install.py lib/spack/spack/cmd/setup.py
Diffstat (limited to 'var/spack/repos/builtin/packages/rendercheck/package.py')
-rw-r--r--var/spack/repos/builtin/packages/rendercheck/package.py48
1 files changed, 48 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/rendercheck/package.py b/var/spack/repos/builtin/packages/rendercheck/package.py
new file mode 100644
index 0000000000..07cc809e9a
--- /dev/null
+++ b/var/spack/repos/builtin/packages/rendercheck/package.py
@@ -0,0 +1,48 @@
+##############################################################################
+# Copyright (c) 2013-2016, Lawrence Livermore National Security, LLC.
+# Produced at the Lawrence Livermore National Laboratory.
+#
+# This file is part of Spack.
+# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
+# LLNL-CODE-647188
+#
+# For details, see https://github.com/llnl/spack
+# Please also see the LICENSE file for our notice and the LGPL.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License (as
+# published by the Free Software Foundation) version 2.1, February 1999.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
+# conditions of the GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+##############################################################################
+from spack import *
+
+
+class Rendercheck(Package):
+ """rendercheck is a program to test a Render extension implementation
+ against separate calculations of expected output."""
+
+ homepage = "http://cgit.freedesktop.org/xorg/app/rendercheck"
+ url = "https://www.x.org/archive/individual/app/rendercheck-1.5.tar.gz"
+
+ version('1.5', '92ddef6d01f02529521af103f9b9bf60')
+
+ depends_on('libxrender')
+ depends_on('libx11')
+
+ depends_on('xproto@7.0.17:', type='build')
+ depends_on('pkg-config@0.9.0:', type='build')
+ depends_on('util-macros', type='build')
+
+ def install(self, spec, prefix):
+ configure('--prefix={0}'.format(prefix))
+
+ make()
+ make('install')