summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/rtmpdump/package.py
diff options
context:
space:
mode:
authorTorbjörn Lönnemark <tobbez@ryara.net>2023-10-26 21:11:43 +0200
committerGitHub <noreply@github.com>2023-10-26 21:11:43 +0200
commit81172f9251ff0b3409b07d5b9d13b214766ff1b1 (patch)
treeeea71cbcf44668c5a52c78ee92c195370760d611 /var/spack/repos/builtin/packages/rtmpdump/package.py
parentcbf9dd0aee8043f86be22806e04cccb81a9afce8 (diff)
downloadspack-81172f9251ff0b3409b07d5b9d13b214766ff1b1.tar.gz
spack-81172f9251ff0b3409b07d5b9d13b214766ff1b1.tar.bz2
spack-81172f9251ff0b3409b07d5b9d13b214766ff1b1.tar.xz
spack-81172f9251ff0b3409b07d5b9d13b214766ff1b1.zip
curl: Fix librtmp variant (#40713)
* rtmpdump: New package * curl: Fix librtmp variant Add the previously missing dependency required for rtmp support. The variant has been broken since its addition in PR #25166. Fixes one of the two issues reported in #26887.
Diffstat (limited to 'var/spack/repos/builtin/packages/rtmpdump/package.py')
-rw-r--r--var/spack/repos/builtin/packages/rtmpdump/package.py38
1 files changed, 38 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/rtmpdump/package.py b/var/spack/repos/builtin/packages/rtmpdump/package.py
new file mode 100644
index 0000000000..a868e6e3d0
--- /dev/null
+++ b/var/spack/repos/builtin/packages/rtmpdump/package.py
@@ -0,0 +1,38 @@
+# Copyright 2013-2023 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
+#
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
+from spack.package import *
+
+
+class Rtmpdump(MakefilePackage):
+ """rtmpdump is a toolkit for RTMP streams."""
+
+ homepage = "https://rtmpdump.mplayerhq.hu/"
+ git = "https://git.ffmpeg.org/rtmpdump.git"
+
+ maintainers("tobbez")
+
+ license("GPL-2.0-or-later")
+
+ version("2021-02-19", commit="f1b83c10d8beb43fcc70a6e88cf4325499f25857")
+
+ variant("tls", default="openssl", description="TLS backend", values=("gnutls", "openssl"))
+
+ depends_on("openssl@:3", when="tls=openssl")
+ depends_on("gnutls", when="tls=gnutls")
+ depends_on("zlib-api")
+
+ patch("missing-include.patch")
+ patch("rtmpdump-fix-chunk-size.patch")
+ patch("rtmpdump-openssl-1.1-v2.patch")
+ patch("rtmpdump-swf_vertification_type_2.patch")
+ patch("rtmpdump-swf_vertification_type_2_part_2.patch")
+
+ @property
+ def build_targets(self):
+ return [f"CRYPTO={self.spec.variants['tls'].value.upper()}"]
+
+ def install(self, spec, prefix):
+ make("install", f"prefix={prefix}", "sbindir=$(bindir)")