summaryrefslogtreecommitdiff
path: root/var/spack/repos/tutorial/packages/armadillo
diff options
context:
space:
mode:
authorPeter Scheibel <scheibel1@llnl.gov>2018-11-06 19:57:32 -0800
committerGreg Becker <becker33@llnl.gov>2018-11-06 19:57:32 -0800
commit7d97e8b0679d50f272c2a131482c352aa63adcf7 (patch)
tree44b1291456982a47a3e62cf46776cd8873713626 /var/spack/repos/tutorial/packages/armadillo
parent058cf81312d07d13b0b6de9949c641892d50ad0b (diff)
downloadspack-7d97e8b0679d50f272c2a131482c352aa63adcf7.tar.gz
spack-7d97e8b0679d50f272c2a131482c352aa63adcf7.tar.bz2
spack-7d97e8b0679d50f272c2a131482c352aa63adcf7.tar.xz
spack-7d97e8b0679d50f272c2a131482c352aa63adcf7.zip
New repo for advanced packaging tutorial (#9711)
* modified tutorial packages * update hint in hdf5 tutorial file (typo for suggested argument) * add repo.yaml to tutorial repository * update tutorial docs to refer user to tutorial package repository * flake edits * recommend site scope vs. defaults * you don't specify the repo's name when adding a repo, just the path
Diffstat (limited to 'var/spack/repos/tutorial/packages/armadillo')
-rw-r--r--var/spack/repos/tutorial/packages/armadillo/package.py62
-rw-r--r--var/spack/repos/tutorial/packages/armadillo/undef_linux.patch4
2 files changed, 66 insertions, 0 deletions
diff --git a/var/spack/repos/tutorial/packages/armadillo/package.py b/var/spack/repos/tutorial/packages/armadillo/package.py
new file mode 100644
index 0000000000..d95a61f67d
--- /dev/null
+++ b/var/spack/repos/tutorial/packages/armadillo/package.py
@@ -0,0 +1,62 @@
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
+#
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
+from spack import *
+
+
+class Armadillo(CMakePackage):
+ """Armadillo is a high quality linear algebra library (matrix maths)
+ for the C++ language, aiming towards a good balance between speed and
+ ease of use.
+ """
+
+ homepage = "http://arma.sourceforge.net/"
+ url = "http://sourceforge.net/projects/arma/files/armadillo-7.200.1.tar.xz"
+
+ version('8.100.1', 'd9762d6f097e0451d0cfadfbda295e7c')
+ version('7.950.1', 'c06eb38b12cae49cab0ce05f96147147')
+ version('7.900.1', '5ef71763bd429a3d481499878351f3be')
+ version('7.500.0', '7d316fdf3c3c7ea92b64704180ae315d')
+ version('7.200.2', 'b21585372d67a8876117fd515d8cf0a2')
+ version('7.200.1', 'ed86d6df0058979e107502e1fe3e469e')
+
+ variant('hdf5', default=False, description='Include HDF5 support')
+
+ depends_on('cmake@2.8.12:', type='build')
+ depends_on('arpack-ng') # old arpack causes undefined symbols
+ depends_on('blas')
+ depends_on('lapack')
+ depends_on('superlu@5.2:')
+ depends_on('hdf5', when='+hdf5')
+
+ patch('undef_linux.patch', when='platform=linux')
+
+ def cmake_args(self):
+ spec = self.spec
+
+ # TUTORIAL: fix the lines below by adding the appropriate query to
+ # the right dependency. To ask a dependency, e.g. `blas`, for the
+ # list of libraries it provides it suffices to access its `libs`
+ # attribute:
+ #
+ # blas_libs = spec['blas'].libs
+ #
+ # The CMake variables below require a semicolon separated list:
+ #
+ # blas_libs.joined(';')
+
+ return [
+ # ARPACK support
+ '-DARPACK_LIBRARY={0}'.format('FIXME: arpack-ng'),
+ # BLAS support
+ '-DBLAS_LIBRARY={0}'.format('FIXME: blas'),
+ # LAPACK support
+ '-DLAPACK_LIBRARY={0}'.format('FIXME: lapack'),
+ # SuperLU support
+ '-DSuperLU_INCLUDE_DIR={0}'.format(spec['superlu'].prefix.include),
+ '-DSuperLU_LIBRARY={0}'.format('FIXME: superlu'),
+ # HDF5 support
+ '-DDETECT_HDF5={0}'.format('ON' if '+hdf5' in spec else 'OFF')
+ ]
diff --git a/var/spack/repos/tutorial/packages/armadillo/undef_linux.patch b/var/spack/repos/tutorial/packages/armadillo/undef_linux.patch
new file mode 100644
index 0000000000..68b434dca8
--- /dev/null
+++ b/var/spack/repos/tutorial/packages/armadillo/undef_linux.patch
@@ -0,0 +1,4 @@
+--- a/include/armadillo_bits/compiler_setup.hpp
++++ b/include/armadillo_bits/compiler_setup.hpp
+@@ -0,0 +1 @@
++#undef linux